Jump to content
CCleaner Community Forums
OLLI_S

5.27.5976 (64Bit) - Timestamp of included folders ignored

Recommended Posts

Hello,

 

I have a problem in CCleaner 5.27.5976 (64Bit) but I am nit sure if this is a bug.

 

I am working with an application called GUI-Analyser (programmed by my company).

The GUI-Analyser creates log files in the folder C:\temp\guianalyser\log.

 

These log files can be really huge, so I Included the folder C:\temp\guianalyser\log in the included folders.

I want to keep the log files for one week (in case there is a bug and the IT needs the log files) so I checked the checkbox "only delete files older than" and entered 168 hours.

This should only delete LOG filed that are older than 7 days (7 days * 24 hours = 168 hours).

 

After creating this rule I deleted all files in C:\temp\guianalyser\log.

After that I started the GUI-Analyser and worked with it (this was 2 days ago).

 

Today I started CCleaner and clicked on "Analyze".

CCleaner found some files in C:\temp\guianalyser\log but these files were created 2 days ago (21st of February).

Normally these files should be ignored (they are not older than 7 days)?

 

Regards

 

OLLI

 

Share this post


Link to post
Share on other sites

have you ticked the option on the Windows tab of CC for Custom Files and Folders ?

Share this post


Link to post
Share on other sites

Hello mta,

 

have you ticked the option on the Windows tab of CC for Custom Files and Folders ?

 

 

I am wondering why you are asking this.

Because I wrote:

 

Today I started CCleaner and clicked on "Analyze".

CCleaner found some files in C:\temp\guianalyser\log but these files were created 2 days ago (21st of February).

Normally these files should be ignored (they are not older than 7 days)?

 

 

So, yes I have checked this options.

CCleaner did found files to delete, but I selected to delete only files that are older than one week.

And these files are 2 days old.

 

Regards

 

OLLI

Share this post


Link to post
Share on other sites

There's an old known "tweak" to turn off "timestamping" actually called NtfsDisableLastAccessUpdate which is system-wide and can cause issues with some programs like backup tools, cleaning tools, etc., so maybe it's worth investigating the system hasn't had that applied and there are some freeware programs that allow enabling and disabling it.

Share this post


Link to post
Share on other sites

Hello,

 

unfortunately I don't have admin rights in our company.

User-Rights are very restricted, I even can not open the registry or install software.

This is the reason why I use CCleaner Portable.

 

So I can not use any tool that changes system settings.

Is there nothing that CCleaner can do?

 

If I set up to only delete files older than 24 hours then this is working (tested on other folders).

Could it be the problem that I set up 168 hours?

 

Regards

 

OLLI

Share this post


Link to post
Share on other sites

I asked OLLI because I seemed to remember reading/finding somewhere that your personal INCLUDES are only honoured if that option is ticked.

and the problem isn't your 168 hours, I have \apple computer\mobilesync\backup set to 336 (2 weeks) for my iphone backups and that works.

Share this post


Link to post
Share on other sites

Maybe both you and @mta can both post the line in your ccleaner.ini (mta your apple sync line; Olli your guianalyser) see what the differences between the two brings out.

Share this post


Link to post
Share on other sites

this is my ccleaner.ini entry; Include15=PATH|%UserProfile%\AppData\Roaming\Apple Computer\MobileSync\Backup\|*.*|RECURSE|1|0|336

 

I just checked that folder and it is empty as that INCLUDE only keeps 2 weeks worth and I haven't backed up the iPhone for a few months.

 

 

So.... I've just run iTunes and backed up the phone, checked the folder and there is data now.

I have now run CC and the folder contents are still intact.

Share this post


Link to post
Share on other sites

Hello,

 

here is my line:

Include2=PATH|C:\temp\guianalyser\log\|*.log||1|0|168

In the folder C:\temp\guianalyser\log there are 12 log files.

They are all from 1st of March, 2nd of March and 3rd of march.

 

If I start CCleaner and right-click on "Custom Files and Folders" then all 12 files are listed.

Although they are not older than 7 days.

 

Regards

 

OLLI

Share this post


Link to post
Share on other sites

so they get listed, but are they all deleted or just the ones older than 168 hours?  (none that old yet, but change the hours to 48 or something just to test things)

Share this post


Link to post
Share on other sites

Hello,

 

here is my line:

Include2=PATH|C:\temp\guianalyser\log\|*.log||1|0|168

 

I wonder if your issue is having two of these after *.log: ||

 

Perhaps test it using this to see if that fixes it:

Include2=PATH|C:\temp\guianalyser\log\|*.log|1|0|168

Share this post


Link to post
Share on other sites

the two || is where RECURSE would be isn't it?

Share this post


Link to post
Share on other sites

Hello,

 

so they get listed, but are they all deleted or just the ones older than 168 hours?  (none that old yet, but change the hours to 48 or something just to test things)

 

They get listed and all get deleted.

So this is not how CCleaner should work.

 

I added the path via the settings dialog (I did not manually edit the ini-file).

 

OLLI

Share this post


Link to post
Share on other sites

no, that is not how CC should work.

and although I have manually edited the .INI file in the past, my INCLUDE was initially put in there from within CC.

Share this post


Link to post
Share on other sites

Hello,

 

could the amount of "Custom Files and Folders" be a problem?

I am using CCleaner Portable at work and I have added for all my colleagues their personal directories.

I have about 20 to 30 "Custom Files and Folders" set up.

 

Regards

 

OLLI

Share this post


Link to post
Share on other sites

wouldn't have thought so, I have 18 INCLUDES and I'm sure CC could handle many, many more.

 

what date in changing (or not changing) on that .LOG file, date accessed, date modified, date created etc....?

and I'm also wondering what group policies have been implemented on your work PC's that may be hindering this whole process.

have you been right clicking the CC portable executable and 'run as admin' ?

Share this post


Link to post
Share on other sites

the two || is where RECURSE would be isn't it?

 

I have allot of RECURSE includes in my ccleaner.ini, none of that have two pipe symbols side by side though: ||

 

Here's two examples one a Path the other a File that I have with just one pipe symbol, like all the rest I have no matter where I've configured CCleaner to clean:

Include3=FILE|C:\Program Files\Registry Mechanic\log\|scan.log|0|0|24

Include8=PATH|D:\Temp\|*.*|RECURSE|0|0|24

 

I mentioned the two pipe symbols in the previous post because they're often the culprit of something not working when for instance making a winapp2.ini cleaning routine - forget them or get them in the wrong place and the cleaning routine won't work - which is one reason I like to manually edit ccleaner.ini so I can see exactly what's going on.

 

Edit:

And something I have no ideal if it's needed or not so that CCleaner honors a time rule, make sure these are enabled/ticked and try again to see if it honors the length of time you have put in place:

 

Options > Advanced > tick/enable both of the 24 hour rules to see if they're the possible reason it isn't working for you OLLI.

Edited by Andavari

Share this post


Link to post
Share on other sites

Hello mta, hello Andavari,

 

what date in changing (or not changing) on that .LOG file, date accessed, date modified, date created etc....?

and I'm also wondering what group policies have been implemented on your work PC's that may be hindering this whole process.

have you been right clicking the CC portable executable and 'run as admin' ?

 

Here are the dates of one of those files (I have a German Windows 7, so I just translated the days but nit the time format):

Created: Friday, ‎10. ‎March ‎2017, ‏‎08:47:37

Modified: Friday, ‎10. ‎March ‎2017, ‏‎08:48:03

Last Access: Friday, ‎10. ‎March ‎2017, ‏‎08:47:37

 

Although I have set "only delete files older than" to 168 hours this file is offered for deletion.

I noticed that one log file created today and an other log file created yesterday afternoon is not offered.

So CCleaner Portable seems to ignore my setting and does delete files older than 24 hours.

 

The same problem occurs no matter if I have the setting "Only delete files in the in the Windows Temp folders older than 24 hours" (in the Advanced Options) enabled or disabled.

Is this a bug?

 

Regards

 

OLLI

Share this post


Link to post
Share on other sites

does it also happen with the normal build?

but, yes, I don't see why the Portable build should behave differently.

Share this post


Link to post
Share on other sites

I posted in our staff area about it where an admin+Piriform employee will see it with a link pointing to this topic.

Share this post


Link to post
Share on other sites

Hello Andavari,

 

thank you!

 

Regards

 

OLLI

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...