Jump to content
CCleaner Community Forums
predcon1

Incorrect HDD model reported

Recommended Posts

post-70282-0-55081600-1487048419_thumb.png

 

The third hard disk listed should read Seagate Firecuda 2TB or something thereabouts, but it repeats the model listed under the first drive. 

Share this post


Link to post
Share on other sites

can you show the Windows version of that screenshot?

 

go to Control Panel, System, Device Manager, expand Disk Drives.

Share this post


Link to post
Share on other sites

Sorry, got swamped, and never received an email notify that I got a reply. 

 

Okay, so Windows is the root cause. What now?

post-70282-0-75968200-1489016157_thumb.png

Share this post


Link to post
Share on other sites

are they all internal drives, or is the 2TB USB connected?

one more area to check, Control Panel, AdministrationTools, Computer Management, Disk Management.

 

apart from that, no idea - only guesses sorry.

any Windows Updates, driver updates, firmware updates possible?

any Service not running - WMI maybe?

 

run Windows Repair from tweaking.com and see if anything helps.

 

of course the effort expended has to be less then the problem! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...