Jump to content
CCleaner Community Forums
Sign in to follow this  
Desperate Recover

Failed to scan the following drives: invalid drive size

Recommended Posts



I'll try to be as concise as possible. 

I've already recovered 945 GB data from a 1.81 TB USB external drive that contains 1.38 TB of data. But after two days of recovery, the process was taking too long and after 3 weeks of recovery !!! the percentage of recovery data was 68 % and the estimated time was 10 days ! So I stopped the recovery process and I launched a new scan.

And the result is this message: "Failed to scan the following drives: invalid drive size"

How is it possible since I've already scanned this drive from which I recovered 945 GB data as mentioned.

What should I do?

Thank you for any help.

Share this post

Link to post
Share on other sites

Hi Desperate Recover, and welcome to the forum.


Your username says it all and I do sympathise. However I don't have a simple answer, and to hopefully get somewhere we need more info from you.


What was the reason for the need to recover data. Faulty drive? Accidental deletion? Accidental format?


What Operating System are you running?


The error message you are getting doesn't seem to have a definitive explanation from any amount of googling, although it usually means that for whatever reason the file system and/or the drive parameters are no longer able to be determined by the host computer.


Without having the drive in front of me I would hazard a guess that ...


a:) The ability to scan and recover with Recuva in the first instance may have been fortuitous and ...


b:) The reason it was fortuitous is that there is a problem with the drive which has manifested itself more seriously when a second scan was attempted.


What happens and what info is displayed when you now attach the drive to your computer?


a:) Does Windows assign a drive letter to it?


b:) In Disk Management, does it show up as having a recognised partition and file system, or does it now show up as "Unallocated Space", or in other words, as a "Raw" drive?


If you can provide as much info as you can, we'll have a look at the possibilities open to you. File recovery isn't an exact science sadly, and it isn't outside the bounds of possibility that if you unplug your drive and reattach it, Recuva might be able to access and scan it again.


Over to you squire, give us all the info you can.

Share this post

Link to post
Share on other sites

Hello Denis and thank you for your answer.


Yes indeed, I'm really desperate but it's fine. Worst things are happening than lost data.


The reason for recovery was a faulty drive. Suddenly, out of nowhere, it was impossible to read it. But I didn't give up and I went on to plug it time to time and one day it "appeared" again on windows explorer as you can see on the picture attached.




I'm running windows 7.


You may see as well on the picture, following your questions, the info displayed and the letter, E, assigned to the drive by windows.


I also attach a pix of my disk management.




As you may see, the disk appears as Disk 3 but not initialized. When I launched the initialization process, it failed (message: "the request could not be performed...")


I'm afraid to unplug the disk.


These are all the info I can give right now. Thank you for your help and your time.

Share this post

Link to post
Share on other sites

Hi DR.


The "I/O device error" shown in your screenshot could be a number of things including a hardware issue like a loose connection. It could be good or bad news and without trying a number of things there isn't an immediate way to tell.


I suggest you have a read here ...




... and follow the different troubleshooting suggestions mentioned. It's a very informative read. Further to one of the suggestions made I've seen it mentioned that restarting your computer in "Safe Mode" may help, simply to eliminate the possible interference of third party software.


You could also download "Seagate Diagnostic Tools" for your drive from here ...




... and maybe find out exactly what is wrong with your drive, or if it is in fact your drive and not your USB input. Have you tried different USB sockets or even another computer?


Lastly, you may still be carrying that bit of good fortune and unplugging and reinserting your drive may just work again for you, because as it stands I don't think any software will be able to access your drive whilst it's experiencing that particular error.


On that point I would be happy to be contradicted.


Anyways, check out the suggestions and then if you need to the Seagate Tools and post back how you get on.


Hope that helps.




EDIT:  If any of my more techie mates on here have other suggestions for this "I/O device error" then please feel free without throwing too much at DR.

Share this post

Link to post
Share on other sites

Hello Dennis and thanks again for your answer.


I read http://www.tech-faq....vice-error.html , I changed the IDE channel transfer properties and it worked ! The disk data are accessible. This a great step.


Nonetheless, when I started the back up of all the disk data, I realized that a lot of files are "corrupted" I get the following message:




I could read those files before the "crash". Do you have any idea about this?


Anyway, thanks a lot again for the help of the article in Tech-FAQ.

Share this post

Link to post
Share on other sites

I'm sorry, off hand I'm not sure, but I would be interested as to whether Recuva can now access and scan the drive.


It's possible that although you can now access the drive, Windows may be having a problem with the file system. I'm thinking of your first screenshot in your second post which shows the drive as now consisting of "Unallocated Space", in other words "Raw" data.


This suggests a possible corruption to the boot sectors of the drive which would mean Windows can no longer read the file system or know the contents of the drive. But bear in mind Windows can only read the drive state from the boot sectors and your files will still be there.


Hopefully, all is not lost if Recuva can no longer scan the drive. As long as the drive is recognized by Windows there are freeware recovery programs which can scan Raw data for files.


And as a last resort there is also the possibility of repairing the boot sector information to restore the drive to it's original state, or to use other freeware to search for and restore the original partition of the drive. A similar end via a different route you could say.


And finally, this all depends on the cause of the "I/O device error" not manifesting itself again.


Try Recuva again and post back. Try the deep scan option if the normal fails.



EDIT:  Forgot to mention, the repair options are a last resort as they are not 100% guaranteed to fix things although they've worked for me in the past.

Share this post

Link to post
Share on other sites

Hello Dennis,


Have a look at a new screenshot of my disk management:




Disk 1 (the "faulty" drive) appears now healthy.


And Recuva can perform a scan without problem:




Thanks again for your help, it was very appreciated.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...