Jump to content
CCleaner Community Forums

Custom Folder Cleaning stops working when "only files older than" is ticked

Recommended Posts

For several years I have used the "INCLUDE Additional Files and Folders to Remove" option to delete all the files from one particular folder every time CCleaner runs.  That has worked fine. 


Recently I decided I would instead prefer that CCleaner delete only files older than 48 hours from this folder, and was pleased to see that there is an option where I can specify this.  Unfortunately, I have found that after I edited my rule by ticking "Only Delete Files Older Than 48 hours" (I had to specify the 48, of course), CCleaner stopped deleting *any* files from the folder, regardless of age.


I have tried deleting and re-creating the rule from scratch, and also updating to the latest version (5.13.5460), but neither move resolved the issue.  If I untick the file-age restriction, it still works fine for deleting *all* files from the folder, but I'd prefer to have the "older than 48 hours only" functionality.


Any suggestions as to how to make this work?  Windows 7.

Share this post

Link to post
Share on other sites

No thoughts?  This seems like a pretty straightforward question.  Would someone mind taking a couple minutes to see if he/she can replicate the issue?  If so, I can be more confident in reporting it as a bug.  Thanks!

Share this post

Link to post
Share on other sites

Here is the INCLUDE I use to only delete iTunes backups older than 2 weeks.


Include13=PATH|%UserProfile%\AppData\Roaming\Apple Computer\MobileSync\Backup\|*.*|RECURSE|1|0|336


which works fine for me.


I have my INCLUDE's, EXCLUDE's etc saved to an INI file.

Share this post

Link to post
Share on other sites

After I enabled INI files I saw that CCleaner had already generated an "Include1" line that looks exactly like the one you suggested (but of course with a different path and 48 instead of 336 -- and without RECURSE since I was not requesting subfolder deletion).  And unfortunately the problem persists.  I re-tried with subfolder deletion but that didn't change anything.  I also thought that maybe the fact that the target folder isn't user-specific might be an issue, so I tested with a user-specific folder and the problem remained.


But thanks for the suggestion, anyway.  Anything else you think might be worth a try?

Share this post

Link to post
Share on other sites

show us the INCLUDE line from the INI file (you never know, something may pop out)

or maybe the entire INI file (for the same reason) :)


the folders in question aren't anything to do with Recycle bin or Windows Temp folders?

Share this post

Link to post
Share on other sites

Thanks.  Here's the INCLUDE line:




Here's the entire INI file, with the individual cookies-to-save list removed.  Note that, other than browser cache and cookies, I do minimal routine browser and system-file cleaning.


UpdateKey=12/22/2014 11:42:03 PM
CookiesToSave=<Cookie list shows up here>
(App)Custom Folders=True
(App)Recently Typed URLs=False
(App)Delete Index.dat files=False
(App)Last Download Location=False
(App)Recent Documents=False
(App)Run (in Start Menu)=False
(App)Other Explorer MRUs=False
(App)Thumbnail Cache=False
(App)Taskbar Jump Lists=False
LastMonitoringNotificationTime=11/03/2014 06:02:00 PM
SystemMonitoringNotificationTime=01/18/2016 02:59:00 AM
(App)ActiveX and Class Issues=True
(App)Adobe Acrobat 9.0=True
(App)Adobe Flash Player=True
(App)Application Paths=True
(App)Autocomplete Form History=False
(App)Chkdsk File Fragments=False
(App)DNS Cache=False
(App)Empty Recycle Bin=False
(App)Gom Player=True
(App)Help Files=False
(App)Invalid File Extensions=False
(App)MS Management Console=False
(App)MS Office Picture Manager=False
(App)MS Paint=False
(App)MS Search=False
(App)MS Wordpad=False
(App)MUI Cache=False
(App)Memory Dumps=False
(App)Menu Order Cache=False
(App)Missing Shared DLLs=True
(App)Mozilla - Compact Databases=False
(App)Mozilla - Cookies=True
(App)Mozilla - Download History=False
(App)Mozilla - Internet Cache=True
(App)Mozilla - Internet History=False
(App)Mozilla - Session=False
(App)NVIDIA Install Files=False
(App)Office 2003=False
(App)Office 2013=False
(App)Office 97=False
(App)Old Prefetch data=False
(App)Run At Startup=False
(App)Sound Events=False
(App)Start Menu Ordering=False
(App)Temporary Files=False
(App)VLC Media Player=False
(App)Windows Defender=False
(App)Windows Error Reporting=False
(App)Windows Event Logs=False
(App)Windows Log Files=False
(App)Windows Media Center=False
(App)Windows Media Player=False
(App)Windows Services=False

Share this post

Link to post
Share on other sites

what is your OS?

just checking (you seemed to indicate you have) you have uninstalled, rebooted and reinstalled CC?

does things differ if ran from Safe Mode?


what are the dates on the files in question, any chance they aren't older than 48 hours???

Share this post

Link to post
Share on other sites

Windows 7 Pro.  Yes to uninstall, reboot and reinstall.  No difference in Safe Mode.


The files in question are far older than 48 hours (created and modified dates), specifically unneeded files from 2013 that I moved to the folder I want time-restricted cleaning for,  just for testing.

Share this post

Link to post
Share on other sites

I'm not sure what date CC refers to, so if Created and Modified are ruled out, what about Last Accessed?

And this is completely left-field, what about that folder (for whatever reason) is at fault.

Test the 24 hour cleaning on another folder.  Even setup a simple named folder, create a few TXT files and do a 1 hour INCLUDE test.


Apart from that, I'm sorry, but that's me done with ideas.

Share this post

Link to post
Share on other sites

Thanks for setting me in the right direction with the "Last Accessed" mention!  But the solution is a little more complex than simply that CCleaner uses Last Accessed date.

BOTTOM-LINE SOLUTION seems to be:  If you have Windows 7, ensure Date Accessed functionality is Disabled, which is the default.  As long as that’s the case, CCleaner will use Date Modified (aka simply “Date”) in determining whether a file meets the user-set age parameter for deletion.  That’s the desired, no-surprises, behavior.  My problem was that (although I had thought otherwise) I had Date Accessed Enabled.

DETAILS (for the record...I’m not sure many will want to read and try to follow :) ):
Experimentation showed that the CCleaner date rules for custom file deletion were indeed using Date Accessed (which seemed kind of odd to me, although I could see it making more sense for *Temp* files, where there is the recommended “only delete older than 24 hours” option.).

Well, it turns out that there are ways Date Accessed, when enabled, can change (become more recent), even without manual access by the user.  (That’s beyond the scope of this post, see links below.)

Now, Date Accessed is actually *disabled* by default in Windows 7 (again see the links below).  Its value can still be viewed, but it most cases it will just be the same as Date Modified.  But at one point a few years ago I had enabled Date Accessed via the method described in the links.  Despite some old documentation to myself saying I had re-disabled it afterward, apparently at some point I had reversed course and re-enabled it again  (or perhaps I hadn’t actually *successfully* re-disabled it?).  In any event, when I first posted -- as it turns out -- Date Accessed was still enabled.

Well, I re-disabled Date Accessed today, hoping this would keep files' Date Accessed values from being changed “behind the scenes” and thus throwing off the CCleaner Custom-folder-cleaning time parameter.

Anyway, after I re-disabled Date Accessed (i.e., back to the Win 7 default), CCleaner switched to using *Date Modified* instead in determining the age of the file.  So it is now working fine, as I initially expected, no surprises.  (This is true even for old files copied or moved from another folder, despite the fact that copying. -- as some commenters mention in one of the links -- still changes Date Accessed to the current date/time in the copy, i.e. the same as the new Date Created.  A file-move will also change Date Accessed to the current date/time, even though a move will *not* change Date Created. Neither copy nor move changes Date Modified.)

One caveat:  Over the years I have had Win 7 I've seen a few minor oddities in file behavior  -- none of which cause any significant problems --  with regard to file dating behavior, so there is a possibility this fix was specific to my system.  But I doubt it.





Edited by Nurick

Share this post

Link to post
Share on other sites

Very glad you got it sorted.

I'm sure it will help others, or at the very least, it'll go into the memory-banks to be searched for at some later time.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...