Jump to content
CCleaner Community Forums

Windows File Explorer won't remember my settings


Recommended Posts

Ok this may only be a small issue but it bugs me continually.

 

I like to store my movie titles by "date created" in Win 10 explorer (right hand pane) not by "Name" alpha ascending/descending.

 

No matter how many times a reset the dam thing after closing and re-opening File Explorer it always reverts back to sort by "Name" alpha, even if I move the "date" column to the first column in the RH pane.

 

Does anyone have any ideas what I'm ding wrong or how to force Win 10 to remember my personal setting?

 

I've done some Google searching on this subject and there are a few out there with the same issue but no one seems to have an answer...........help please 

Link to post
Share on other sites
  • Moderators

How are you setting it?

Are you using 'Sort By' from the 'View' ribbon menu, or clicking on the column heading?

 

It works fine for me using either, but I usually use the column heading method.

Open file explorer and browse to Documents.
Click on 'date modified' to re-order the files by date. (Click it again if you want oldest first)
Close file explorer.
Reopen file explorer, browse back to Documents, files are still in date order.

I do have file explorer pinned to the taskbar, not sure if that would make a difference.

I have also not tried logging out and beck in to see if it still keeps the settings.

Which edition are you using - Home, Pro, or Enterprise?

If you are on Pro or Enterprise than have you updated to TH2 yet?

Link to post
Share on other sites

nukecad I'm using Win 10 64bit "Home", file explorer is pined to my taskbar, I am selecting "date created" then "date modified" from the column heading as I have always done going back as far as I care to remember, many OS's ago.

 XP/2000/NT/Server 2008, it's only Win 10 that is giving me issues. I may be forced to do a "reflect" restore. I generally (no always) lose the settings when I log off/warm restart/cold start.

 

Interestingly I do not have this issue on my Win 7 PC.

 

Thanks for you comment I'll keep looking before I do a restore which is not an issue as it only takes 14 minutes.

Link to post
Share on other sites
  • Moderators

Further to this,

 

Although the setting remained and files were displayed ordered by date for the rest of the session, it was lost on shut down.

 

After booting today the file explorer was ordered by filename again.

I haven't checked with a restart, may try that in a miniute or so.

 

I don't have the 'Date Created' showing in file explorer, just the 'Date Modified'.

I'm not sure why you are clicking both column headings?

Why not just the 'Date modified' if thats how you want them ordered?

 

 

I do always run CCleaner before logout, so this may clear the setting.

I would have to play about to see if this is the case.

 

I'm not sure that a restore/repair of Windows is the way to go, seems a bit drastic for such a minor issue.

 

Is it realy such a hardship to give one (or 2) cicks on the column heading at the begining of each session?

(Its the sort of thing where once you get used to doing it, you will do it automatically without noticing).

 

Just for completeness I also am running Windows 10 Home 64-bit.

Link to post
Share on other sites
  • Moderators

Well this is interesting;

 

After writing the above I went off to have a play, here's the results-

 

Opened File Explorer, browsed to documents and clicked the column heading to order files by 'Date modified'.

Closed FE.

Ran CCleaner.

Opened FE, browsed to documents. This was still ordered by 'Date modified'.

 

Closed FE.

Did a restart.

Opened FE, browsed to documents. This was still ordered by 'Date modified'.

 

Closed FE.

Shut Down.

Booted.

Opened FE, browsed to documents. This was still ordered by 'Date modified'.

 

 

From that it seems to be keeping the setting on my laptop even through a Shut Down and re-Boot.

(Although it did seem to loose it when I shut down last night?)

 

It may be some other setting in Win 10, but I don't know which (yet).

 

I have to go and do a bit of work now;

but I am intrigued by this and may try later to see if I can find some way to replicate what Tasgandy is seeing.

(It will give me something to pay with later).

Link to post
Share on other sites
  • Moderators

nukecad you don't have Windows Size/Location cache ticked under Ccleaner Advanced Windows Files do you?

No, the only thing I have selected in Advanced is 'Old prefetch data'.

And as reported in that last post CC had no effect on MY file order.

 

Of course I can't say what CC options Tasgandy has selected though.

Link to post
Share on other sites
  • Moderators

Well I tried cleaning the Windows Size/Location Cache and it made no difference, files were still ordered by date.

 

I think that this is an OS problem, not CCleaner.

 

I have found another couple of possible causes of this reported behaviour.

 

Tasgandy,

 

Are you using ESET anti-virus?

(It is reported, and acknowledged, as causing FE settings problems on Win 10. It usually messes with desktop icons as well).

 

Do you have a lot of folders on your PC?

(There is a limit as to how many the settings can be remembered for, if you have more than this limit then further changes can not be remembered without a registry change).

Link to post
Share on other sites
  • Moderators

Do you have a lot of folders on your PC?

(There is a limit as to how many the settings can be remembered for, if you have more than this limit then further changes can not be remembered without a registry change).

 

That problem has existed for a longtime before Win10. What I've did in XP to get around it is set up a view that I want system-wide and then via Folder Options set all folders to have the same view. Of course that may not work the same on Win10.

Link to post
Share on other sites
  • Moderators

That problem has existed for a longtime before Win10. What I've did in XP to get around it is set up a view that I want system-wide and then via Folder Options set all folders to have the same view. Of course that may not work the same on Win10.

I believe it does, and it is one of the registry changes that can be made.

A problem with this in win 8,8.1, & 10 is that they have different default folder templates for different types of files active at the same time.

(You can have different default views for General, Document, Photo, Music, Video, etc. all at the same time).

The registry modification as used in XP, Vista, and 7 changes all of these different folder templates to be the same system wide.

 

There is another registry change that just allows you to increase the folder limit by creating a new reg entry.

 

But I thought it best to see if this was the problem before posting or linking to any registry changes.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...