Jump to content

WD My Book Essentials External Drive Not Recognized By OS After Running CCleaner


Recommended Posts

I am currently using Mac OS Mavericks 10/9.5 on a 2011 Macbook Pro 17" laptop. Were there cache files on my Mac that were wiped out when it was run? If so, how can I restore them, or undo what was done earlier this week when I ran the program?


Running the Disk Utility does not show or recognize the external drive at all. I tried hooking it up to my older Mac desktop with Data Rescue software, it cannot see the drive either. I bought a new USB cord to see if it would help, but no help there either.


When I unplug the External drive and then reapply power to it, you can hear it spin up, and the heads are active also for several seconds. So, I know the thing is not dead, and there was no noises or "click of death" scenarios preceding this problem.



Please advise of any fixes, patches, etc. that might help, thank you

MD :-)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.