Jump to content
CCleaner Community Forums

Ccleaner crash report


super

Recommended Posts

c35fbe90-7bc8-4959-b7a6-27bc923fd297.zipNergal,

 

Updated to 5.10 and, at first run, using debug4, it crashed.

 

CCleaner_v5.10.5373_2015-10-12_22-13-59.log shows:

[22:13:59::425][iNFO ] CCleaner v5.10.5373
[22:13:59::425][iNFO ] Windows 7 Ultimate 32-bit SP1
[22:13:59::425][iNFO ] AMD Athlon 64 X2 Dual Core Processor 3800+
[22:13:59::425][iNFO ] 2,0GB RAM
[22:13:59::425][iNFO ] NVIDIA GeForce GT 640
[22:13:59::425][iNFO ] Username: Eolo

[22:13:59::441][iNFO ] Application Started

 

Dump file attached, as ZIP:

c35fbe90-7bc8-4959-b7a6-27bc923fd297.dmp

Link to post
Share on other sites

Test made in one of my computers.
Pls let me know if, after solving this one, you would like to see the other machines error log.

Now, going back to 5.09... :-)

Link to post
Share on other sites

I set up CCleaner in my main computer to start with the /debug command. The first run the program worked okay. A log file was created showing everything I did. But the second run the program froze, nothing happened. After a minute I had to close it by force. A DMP file was created but it was 0 bytes. The Log file only saved this:

 

 

[22:45:48::058][iNFO ] CCleaner v5.10.5373 (64-bit)
[22:45:48::058][iNFO ] Windows 7 Home Premium 64-bit SP1
[22:45:48::058][iNFO ] Intel Core i5-2500K CPU @ 3.30GHz
[22:45:48::058][iNFO ] 8,0GB RAM
[22:45:48::058][iNFO ] AMD Radeon HD 7700 Series
[22:45:48::058][iNFO ] Username: Azrael


[22:45:48::058][iNFO ] Application Started
 

 

Now I changed /debug to /debug4 to log only the errors.

 

One thing I noticed, if it matters, Eolo and I are both from South America, Eolo from Brazil (Portuguese) and I from Chile (Spanish). Can be the regional language set in Windows be related to the problem? (And by the way, I prefer to use my software -programs and games, including CCleaner- in English and not in Spanish, even though my Windows O.S. is in Spanish).

Link to post
Share on other sites
  • Moderators

Awesome thanks guys, that may help the developers work on this issue

Link to post
Share on other sites

It happened again, this time I was able to send a report. Although I'm not sure if a DMP file was sent and then deleted, because no such DMP file for this instance was in CCleaner's folder.

 

The log file with the /debug4 command saved this (exactly like last time):

 

 

[23:18:49::892][iNFO ] CCleaner v5.10.5373 (64-bit)
[23:18:49::892][iNFO ] Windows 7 Home Premium 64-bit SP1
[23:18:49::892][iNFO ] Intel Core i5-2500K CPU @ 3.30GHz
[23:18:49::892][iNFO ] 8,0GB RAM
[23:18:49::892][iNFO ] AMD Radeon HD 7700 Series
[23:18:49::892][iNFO ] Username: Azrael


[23:18:49::892][iNFO ] Application Started
 

 

Also, a file named "ccleaner_checkpoint.dat" was also created. It only had this:

 

 

GBP1
20151013
1

 

 

That's all I can report for now. I hope it helps.

Link to post
Share on other sites

Sorry to hear that others are still having the problem.  I still have not had any crashes.  When I deleted CC I used Revo Uninstaller Pro.  It does a more thorough uninstall of programs than Window's control panel.  I had also monitored all my previous installs with Revo which also insures a more thorough deletion.  Still have not had a crash of CCleaner in five days, I use it at least once a day.  

 

Computer is a Window 7 Pro, with all the ms updates.

Link to post
Share on other sites

Here’s another one.

Updated CC to v5.10, runned it with /debug4 and it crashed. This time, I was able to add my email to the “send error report”.

 

I checked the CC folder, but there’s no DUMP (?), just the LOG file, which contains the following:

[09:34:15::463][iNFO ] CCleaner v5.10.5373 (64-bit)

[09:34:15::463][iNFO ] Windows 7 Ultimate 64-bit SP1

[09:34:15::463][iNFO ] Intel Core i7-3610QM CPU @ 2.30GHz

[09:34:15::463][iNFO ] 6,0GB RAM

[09:34:15::463][iNFO ] Intel HD Graphics 4000

[09:34:15::478][iNFO ] Username: Asus

 

[09:34:15::478][iNFO ] Application Started

[09:34:27::409][iNFO ] Closing application...

[09:34:27::425][iNFO ] Finished closing application

[09:34:27::425][iNFO ] Application Ended

Link to post
Share on other sites
  • Moderators

EOLo I don't see a crash in the last one I see a full open and close.

Link to post
Share on other sites

Nergal, that’s the 'spooky' thing.

 

When it crashed, the “send a report to CC” windows opened and I had the chance to type in my e-mail, hit send and see the message “sent”, before Windows shut it down.

 

Then I went to CC folder and there was no dump there. Just this “normal” log.

 

Maybe you could check with CC, see if they received my email (), based on the date/time showed in the log?

 

Link to post
Share on other sites
  • Moderators

Uh I'm removing your email address. Public displays of email draw spammers to you and the forum itself.

Link to post
Share on other sites

Well, I tried uninstalling and then reinstalling this latest build of CCleaner, but doing so did not fix the crashing issue. It has either got to be in the code itself or (extremely unlikely) a leftover registry key from the previous build.

Well, it has to be related to the new change introduced in v5.10.5373 for faster start up. From the version history ( https://www.piriform.com/ccleaner/version-history ):

  • Optimized internal architecture for faster start up.

 

The funny thing, I never noticed before that it was slow to start. For me, CCleaner was really fast to open, always in an instant.

Link to post
Share on other sites

Sorry to hear that so many are still having troubles. Ever since I deleted with Revo-Uninstaller Pro (which is not free), I have not had a crash. Before then CCleaner would often crash at the first attempt to open, second time would be ok. I think that using Revo was able to delete the offending remnant before I did my re-install of CCleaner. There are some other programs that will delete programs from your system and do a more thorough job than the included windows un-installer. Here is the page at Gizmo's with their ratings of free uninstall programs.

 

Link to post
Share on other sites
  • Moderators

Yeah I removed the link above, it's not really relevant to helping solve this is (people can look it up if they like, but it comes close to infringing on features that piriform software performs imho)

Link to post
Share on other sites

Nergal, how can you completely delete CCleaner using CCleaner?  Revo does a much more thorough job of exorcising a program and its tentacles from your computer than the built in Windows or CCleaner's (especially when CCleaner is what you want to delete),  When I tried just using Windows to delete CCleaner before a re-install the crashing of CC did not disappear, but when I used my Revo Pro to completely rid my system of CCleaner and then did a fresh installation, I have not had the crash since.  I of course had to reset my preferences, but It has been three weeks now, and I use CCleaner daily, without a crash since.

 

 I was one of the first to report this problem in this thread, and have not had a recurrence since doing as I suggested.   

Link to post
Share on other sites
  • Moderators

I didn't remove reference to revo's removal, I removed reference to a general freeware article which doesn't help. Revo is different because it monitors installation process so it can fully remove traces.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...