Jump to content
CCleaner Community Forums

Office 2010 - Recent Documents


Recommended Posts

Hello,

 

I have Microsoft Office 2010 and have pinned some important Excel-Files to the "Recent" list in Excel.

After running CCleaner they are gone.

 

In CCleaner I went into the details of "Applications - Office 2010" and right cklicked on the Excel-Files (FileName.xls.LNK) and selected "Add to Exclude List".

They are located in the folder C:\Users\<MyUsername>\AppData\Roaming\Microsoft\Office\Recent

After closing Excel and running CCleaner my "Recent" list in Excel is still empty.

 

What can I do to keep my recent documents in Excel?

 

Greetings

 

OLLI

Link to post
Share on other sites
  • Moderators

add this;

 

%UserProfile%\AppData\Roaming\Microsoft\Office\Recent\

 

as an EXCLUDE

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; Birth, Death and loss of data. You control the last.

Link to post
Share on other sites

Hello,

 

I went to the Options -> Exclude and clicked on Add.

Then I selected "Drive or Folder" and added your String.

 

Unfortunately the Recent documents are still gone after cleaning.

 

OLLI

Link to post
Share on other sites
  • Moderators

You should be able to stop it by unticking in CCleaner:

Office 2010

 

Note that disabling the Office 2010 cleaner will mean that CCleaner won't clean it at all.

 

This is why you'd need to untick it, it's because the recent documents are in the Office 2010 cleaner:

FileKey1=%AppData%\Microsoft\Office\Recent|*.*

 

 

Edit:

That exclude that mta posted might work this way instead (since CCleaner is rather particular to get some excludes to properly work):

C:\Users\Your User Profile Name\AppData\Roaming\Microsoft\Office\Recent\|*.*
Edited by Andavari
Link to post
Share on other sites

Hello Andavari,

 

 

That exclude that mta posted might work this way instead (since CCleaner is rather particular to get some excludes to properly work):
C:\Users\Your User Profile Name\AppData\Roaming\Microsoft\Office\Recent\|*.*

 

I have problems entering this in the Options of CCleaner.

 

The String that I am using is (here in the Forum I replaced my username with <UsernameA:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\|*.*

 

I went to the Options and added the string as a "File" (Radiobutton "File" is seleccted).

When I go to "Cleaner" and then back to the options then I see that the |*.* at the end of the string is truncated:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\

 

So I removed the old entry and added it as a "Folder".

When I go to "Cleaner" and then back to the options then I see:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\*.*\

 

Why is this so complicated?

 

Why is ist not woking when I add a specific excel file here:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\MyExcelFile.xlsx.LNK

 

I also added an exclude path

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\*.*

But also here all Recent Documents are deleted.

 

Greetings

 

OLLI

Link to post
Share on other sites
  • Moderators

The best way I can explain this is via these instructions - I did say it was particular in excluding some things.

 

What I had to do a long time ago was have all the settings stored in ccleaner.ini instead of the registry, it's much easier to edit the settings with Notepad when they're all in the INI:

1. Open CCleaner.

2. Go into 'Options > Advanced' and click 'Save all settings to INI file'

 

After having CCleaner 'Save all settings to INI file':

1. Re-input your Exclusion again, then close CCleaner.

2. Open the ccleaner.ini file located in the folder where CCleaner is installed.

3. At the end of your exclude file/path paste this at the very end of it: \|*.*

4. Save the INI file.

For whatever reason and I don't know why that upperslash  (if that's what it's called) is needed!

 

------------

 

So this whole folder path you've been trying to exclude won't get excluded because the upperslash | is missing:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\*.*

 

It needs to become this:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\|*.*

 

------------

 

You're also trying to exclude a single file which also won't work because the upperslash | is missing:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\MyExcelFile.xlsx.LNK

 

It needs to become this:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\|MyExcelFile.xlsx.LNK

 

------------

 

Note that I don't know how CCleaner will treat a "Recent" folder, and don't know if it will honor the exclude even if it's inputted correctly. You may still need to untick Office 2010 so that CCleaner won't clean any of it.

 

I would be nice if Piriform would finally eliminate the need for the upperslash!

 

 

------------

 

Edit:

 

Examples of how this would look in ccleaner.ini (you could just copy+paste this and then edit the username part by inputting your actual username -- and do note the excludes are numbered like Exclude1, Exclude2, etc.):

Exclude1=PATH|C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\|*.*
Exclude2=FILE|C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\|MyExcelFile.xlsx.LNK
Edited by Andavari
Link to post
Share on other sites
  • Moderators

I had your exact problem @OLLI_S and this has been working for me for years.

 

And as @Andavari says, maybe it works better from the .ini file rather than the registry side of it.

 

I have an .ini file with;

 

Exclude1=PATH|%UserProfile%\AppData\Roaming\Microsoft\Office\Recent\|*.*

(App)Recent Documents=False

(App)Office 2003=False
(App)Office 2007=False
(App)Office 2010=False
(App)Office 2013=False

 

And I've never had CC wipe my Office recent items since.

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; Birth, Death and loss of data. You control the last.

Link to post
Share on other sites

- When I look at the content of "Winapp1.ini" then it looks like that the last used files by Office 2010 are stored in the registry (as well). I see over there this line:

 

"RegKey28=HKCU\Software\Microsoft\Office\14.0\Excel\File MRU"  (MRU is the abbreviation of "Most Recently Used").

 

And CC removes those MRU registry entries as well. I could imagine that MS Office "doesn't" like that this registry entry is removed as well and then will delete those "*.lnk" files as well.

 

- If CC cleans a number of files in that "Recent" folder then those should show up in the list of files to be deleted. No need to do a "test clean".

 

But CC won't mention which registry entries are going to be cleaned.

System setup: http://speccy.piriform.com/results/gcNzIPEjEb0B2khOOBVCHPc

 

A discussion always stimulates the braincells !!!

Link to post
Share on other sites
  • Moderators

- When I look at the content of "Winapp1.ini" then it looks like that the last used files by Office 2010 are stored in the registry (as well). I see over there this line:

 

"RegKey28=HKCU\Software\Microsoft\Office\14.0\Excel\File MRU"  (MRU is the abbreviation of "Most Recently Used").

 

When I looked at what it cleaned I saw that which was why I suggested unticking/disabling the cleaning of Office 2010.

Link to post
Share on other sites

Quote:

 

"Why is ist not woking when I add a specific excel file here:

C:\Users\<Username>\AppData\Roaming\Microsoft\Office\Recent\MyExcelFile.xlsx.LNK"

 

Quite simple. In this case CC will look for a folder (with the attribute "folder") called "MyExcelFile.xlsx.LNK". When you insert the "|" between "Recent\" and "MyExcelFile.xlsx.LNK" then that will tell CC it must look for a file (without the attribute "folder") called "MyExcelFile.xlsx.LNK".

 

Put another way: The characters in front of the 1st "|" are treated as a pathname and the characters behind the 1st "|" are read as a filename.

System setup: http://speccy.piriform.com/results/gcNzIPEjEb0B2khOOBVCHPc

 

A discussion always stimulates the braincells !!!

Link to post
Share on other sites
  • 2 weeks later...

Although it is a recent event, I'm now having the same problem. What I don't understand in this discussion is why unchecking "Recent Documents" and "Other Explorer MRUs" options does not do the trick? What are these options for, if not for this specific issue?

Link to post
Share on other sites

i have also try it...

 

it i pinned a excel file and cleaned with ccleaner with checked option "office 2010" -> it will be deleted (with exclude too)

Versions of CCleaner Cloud; Die Toten Hosen - Altes Fieber

Ccleaner-->System-Requirements; Ccleaner FAQ´s; Ccleaner builds; Scheduling Ccleaner Free

 

Es ist möglich, keine Fehler zu machen und dennoch zu verlieren. Das ist kein Zeichen von Schwäche. Das ist das Leben -> "Picard"

Link to post
Share on other sites

--> with exlude "HKCU\Software\Microsoft\Office\14.0\Excel\File MRU"

(with checked option "office 2010" the pinned are there but the mru´s too)

Versions of CCleaner Cloud; Die Toten Hosen - Altes Fieber

Ccleaner-->System-Requirements; Ccleaner FAQ´s; Ccleaner builds; Scheduling Ccleaner Free

 

Es ist möglich, keine Fehler zu machen und dennoch zu verlieren. Das ist kein Zeichen von Schwäche. Das ist das Leben -> "Picard"

Link to post
Share on other sites

you know what's really funny?

in the Office 2010 Starter Edition is in "last used" and "last visited" nothing erased, not even with ticked "Office 2010" in Cleaner

 

no matter if pinned or not.

 

i have tryed 4.19 and 5.06

Versions of CCleaner Cloud; Die Toten Hosen - Altes Fieber

Ccleaner-->System-Requirements; Ccleaner FAQ´s; Ccleaner builds; Scheduling Ccleaner Free

 

Es ist möglich, keine Fehler zu machen und dennoch zu verlieren. Das ist kein Zeichen von Schwäche. Das ist das Leben -> "Picard"

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...