Jump to content
CCleaner Community Forums

Ccleaner uninstall Arcobat reader DC when I run registry cleaner

Recommended Posts

What reason?

Can you be more specific?

Is it all those 15 reg keys, or just the ActiveX and Class Issues or just the Type Libraries?

have you tried to isolate it to a specific key in that list?

does cleaning all those keys uninstall Reader or just give you an error the next time you use it?

Share this post

Link to post
Share on other sites



Unfortunately, we haven't been able to reproduce this problem.


When deleting these Registry entries, Adobe Reader DC still works as expected.


The application it is not uninstalled by removing those Registry keys.


Would you be able to provide us with a video or set of snapshots to illustrate the problem?



Share this post

Link to post
Share on other sites

Hi, I'm having the same problem. I wrote this same content on the post linked above. The applicacion (Adobe Acrobat DC) is not being uninstalled, there are some specific keys that are being deleted causing Adobe Reader DC to reconfigure itself like if it is being installed by the first time.


These are the steps to reproduce the problem:


- Clean the registry.

- Open Adobe Reader DC from the app icon, not by opening a PDF document. It will reconfigure itself again.


I'm using Adobe Reader DC 2015.007.20033 in Spanish.



These are the keys that are being deleted:



ActiveX/COM Issue LocalServer32\"C:\Program Files (x86)\Adobe\Acrobat Reader DC\AcroRd32Info.exe" /PDFShell HKCR\CLSID\{98D9A6F1-4696-4B5E-A2E8-36B3F9C1E12C}

ActiveX/COM Issue LocalServer32\"C:\Program Files (x86)\Adobe\Acrobat Reader DC\AcroRd32Info.exe" /PDFShell HKCR\CLSID\{D38406DA-E8AA-484b-B80D-3D3DBDCC2FB2}

Missing TypeLib Reference IAcroAXDoc - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{08A9E040-9A9C-4F42-B5F5-2029B8F17E1D}

Missing TypeLib Reference CAcroApp - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3E6-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroPDDoc - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3E7-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroAVDoc - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3E8-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroAVPageView - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3E9-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroPDPage - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3EA-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroPDAnnot - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3EB-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroPoint - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3EC-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroRect - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3ED-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroTime - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3EE-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroPDTextSelect - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3EF-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroHiliteList - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3F0-4981-101B-9CA8-9240CE2738AE}

Missing TypeLib Reference CAcroPDBookmark - {E64169B3-3592-47D2-816E-602C5C13F328} HKCR\Interface\{9B4CD3F1-4981-101B-9CA8-9240CE2738AE}


Sorry, I could attach them in a txt file but I did not see the option.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...