Jump to content
CCleaner Community Forums

Analyze & Run cleaner's buttons not showing correctly


benbxl
 Share

Recommended Posts

perhaps uninstall and then reinstall the 5 new again?
 
it's worth a try

Versions of CCleaner Cloud; Introduction Ccleaner Cloud;

Ccleaner-->System-Requirements; Ccleaner FAQ´s; Ccleaner builds; Scheduling Ccleaner Free

 

Es ist möglich, keine Fehler zu machen und dennoch zu verlieren. Das ist kein Zeichen von Schwäche. Das ist das Leben -> "Picard"

Link to comment
Share on other sites

  • Moderators

@benbxl,  what's the problem with those buttons?  are they greyed out and not 'clickable' ?

 

@hhumphrey, what OS?, what CC version? (v5 or v5.01)

 

do either of you use winapp2.ini or any other add-on to CC?

does it also happen in Safe Mode?

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; Birth, Death and loss of data. You control the last.

Link to comment
Share on other sites

Try and see if this makes the buttons clickable:

 

Open CCleaner > Options > Advanced > tick "Save all settings to ini file". Close CC.

 

Go to My Computer > C > Program Files > CCleaner, and move the winapp.ini file somewhere else (desktop probably best)

 

Re-open CC. Are the buttons immediately clickable?

Link to comment
Share on other sites

  • Moderators

That's because the above given advice is incorrect, I believe they meant for you to move the ccleaner.ini file. Note, do not throw the file away as what he is proposing, while I think it a good idea, will remove all of your ccleaner preferences and choices.

If you keep the file, and this doesn't work, you can place the file back in the folder (overwriting the one it created)

If this does work we'll work on getting the good preferences back into ccleaner

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

  • Moderators

Ok, so next open both the ccleaner.ini file in the ccleaner folder (newly created when you started ccleaner after the file move) and the one you moved.

Copy/cut the section(s) from the old file for cookies to keep, any excludes/includes and paste them into the new .ini file.

 

Optional: After saving the new ini and throwing away the old you can uncheck save settings to ini and it will move them back to the registry

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

So a new ccleaner.ini file does not appear in the ccleaner folder. 

 

I then tried restarting my computer to see if a new ccleaner.ini file would appear.

 

It didn't and I tried running ccleaner again and it reverted to my original problem of the buttons grayed out and not being clickable?

 

Note after I restarted my pc and loaded ccleaner I went into the settings and the save settings to ini option was not ticked.

Link to comment
Share on other sites

  • 2 weeks later...
  • Moderators

It sounds like you aren't running ccleaner with high enough administrator permission (UAC) to write in the folder Ccleaner is installed in. Please right click ccleaner and choose run as admin. Then attempt to save setting in ini

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

I am still having this issue.

 

I have attached the old ini file i.e. the one I moved and the new one which was created when I restarted my PC and went back into cclenaer and ticked the option to Save all settings to ini file.

 

I am not sure if this is of any use, but when both buttons are disabled I am also not able to scroll down the list of programs on the left hand side, it just continuelly shows the mouse cursor as busy when ever I hover over that part of the screen.

 

If I go onto the registry cleaner tab while the analyse and run cleaner buttons are disabled on the cleaner tab. I can click on the scan for issues but this just freezes and stays at 3% constantly

 

OLD INI - one which was moved

 

[Options]
Language=1033
SkipUAC=1
UpdateKey=12/25/2014 11:10:50 PM
WipeFreeSpaceDrives=C:\
CookiesToSave=*.piriform.com|accounts.google.com|aol.com|facebook.com|google.com|mail.google.com|twitter.com|www.google.com|yahoo.com
RunICS=0
Monitoring=1
SystemMonitoring=1
CheckTrialOffer=0
WINDOW_LEFT=283
WINDOW_TOP=64
WINDOW_WIDTH=800
WINDOW_HEIGHT=600
WINDOW_MAX=0
SystemMonitoringRunningNotification=0
LastMonitoringNotificationTime=12/25/2014 11:14:08 PM
LMN=2|3|0|0|0|0|1|0|0|0||||
 
 
NEW INI - after restart and going back into ccleaner file and ticking the option to save settings to ini
 
[Options]
CheckTrialOffer=0
CookiesToSave=*.piriform.com|accounts.google.com|aol.com|facebook.com|google.com|mail.google.com|twitter.com|www.google.com|yahoo.com
LMN=2|3|0|0|0|0|1|0|0|0||||
LastMonitoringNotificationTime=12/25/2014 11:40:40 PM
Monitoring=1
NewVersion=
RunICS=0
SystemMonitoring=1
SystemMonitoringRunningNotification=0
UpdateKey=01/10/2015 09:17:48 AM
WINDOW_HEIGHT=600
WINDOW_LEFT=283
WINDOW_MAX=0
WINDOW_TOP=64
WINDOW_WIDTH=800
WipeFreeSpaceDrives=C:\
 
Link to comment
Share on other sites

Hi hhumphrey,

 

Please add an empty file called "winapp1.ini" in the same folder as your CCleaner.exe installation.

 

This will override the embedded "winapp.ini" and cause the "Applications" tab to be empty. 

 

Let us know if buttons become enabled.

Link to comment
Share on other sites

I added a file called winapp1.ini as you stated. CCleaner won't even load

 

I then added a file called ccleaner1.ini as I am not using the extension and ccleaner wouldn't load

 

I then went and added a empty ccleaner.ini file and ccleaner wouldn't load

Link to comment
Share on other sites

  • 3 weeks later...

Hi hhumphrey,

 

Please, remove "ccleaner1.ini" as it it not needed.

 

What happens when you also delete the empty "winapp1.ini"? 

 

Does CCleaner start correctly but still has disabled buttons?

 

If so, you can also try creating an empty "winsys1.ini". This will override the embedded "winsys.ini" and cause the "Windows" tab to be empty.

 

Let us know.

 

Thanks

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

I have a similar problem.  Unlike your situation, however, my "analyze" and run cleaner" buttons aren't grayed out--they're missing altogether.  That, of course, renders cc cleaner completely useless, as the program can't be run.

 

I've uninstalled and reinstalled cccleaner, to no avail.  Anyone know of a program similar to cc cleaner?  Because Piiform's version doesn't perform.  (Almost rhymes. doesn't it?)

Link to comment
Share on other sites

  • Moderators

memphisbelle11 what is your operating system?

 

Do you have any 'start programs' such as classic shell?

 

Any different Windows 'skin' you are using, or is everything the default?

 

Just as a test if you change your screen resolution do the buttons show then?

 

http://windows.microsoft.com/en-gb/windows-vista/change-screen-resolution

CCleaner documentation can be found here

https://www.ccleaner.com/docs/ccleaner

Support contact

https://support.piriform.com/hc/en-us/requests/new

support@ccleaner.com

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...