Jump to content
CCleaner Community Forums

ccleaner v.5 won't install in windows 8.1


dfulton
 Share

Recommended Posts

I have been a Ccleaner user for years and have always been pleased with the way it works and the ease with which it updates. I recently updated to v.5 on my desktop running windows 7 without a hitch. Tried to download and install the same new v.5 to my Surface Pro tablet running windows 8.1 but it won't work. When prompted to open or save the download and I tap open, it hangs and does nothing. If I tap save and try to run the exe file from the download folder, I get a message asking which program do I want to use to run the program and it suggests Internet Shortcut Shell Extension DLL but when I tap that, nothing happens except the same error message window opens again, and again, and again.

 

I have tried disabling my firewall and windows defender anti virus but no luck........ same sequence. I tried booting into safe mode and installing from there but still no luck....... same sequence of errors. I'm afraid to remove v.4.19 because I wouldn't have a working cleaner program.

 

Obviously, v.5 is not compatible with windows 8.1.  If no one has come up with a workaround, I guess I just have to stay with the older version until Piriform comes out with a patch.

Link to comment
Share on other sites

  • Moderators

1. Do you have an older version of CCleaner installed?

2. Check the process list in Task Manager to see if there are any CCleaner processes running. (Let me know if there were)

3. If there are CCleaner processes kill them and then try installing.

 

 

Also don't worry about having a working version, you can always re-download 4.19  from here

 

http://filehippo.com/download_ccleaner/59127/

CCleaner documentation can be found here

https://www.ccleaner.com/docs/ccleaner

Support contact

https://support.piriform.com/hc/en-us/requests/new

support@ccleaner.com

 

Link to comment
Share on other sites

There was one CCleaner process running in Task Manager. I ended it and tried to install v.5 but I got the same error messages:

 

If I select "open" to run the v.5 download, it freezes and nothing happens.

 

If I select "save" then double tap on the saved file (ccsetup500_exe), I get the "How do you want to open this file?" message with Internet Shortcut Shell Extension DLL program recommended. When I select that, nothing happens.

 

Yes, I have version 4.19 installed. Since you told me where I can go to re-install that version, I removed it from the tablet and tried to install v.5 from the saved downloaded file but still got the same error messages.

 

I noticed, however, that the downloaded v.5 file was named "ccsetup500_exe" with no period (".") included in the name so, on a flier, I changed the file name to "ccsetup500.exe" (changed the underscore "_" to a period ".") and tried it. Didn't get any error messages and it installed like a charm.

 

Why in the world would they give you a version application file to download and have it be unusable since it is named incorrectly????

 

The wonderful world of computers!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...