Jump to content
CCleaner Community Forums
Sign in to follow this  
pompste

Ccleaner.exe---no disk in drive D.

Recommended Posts

Hi,

Everytime after i get done playing a cd in my D drive and then run CC afterwards a warning pops up "ccleaner.exe - no disk in drive D". I click to cancel and nothing happens,so i have to kill the process in task manager,and then the warning comes back again after i click the Ccleaner icon.Only solution so far is to reboot the pc.

I`ve checked the "hide warning messages" and it still does it.I`ve uninstalled and reinstalled Ccleaner and same problem happens.

Running Windows 7 home premium.

Any fixes for this problem? Rebooting my pc everytime after i play a cd is wearing thin.

Share this post


Link to post
Share on other sites

Hi pompste.

 

Try putting a blank disk into the drive and then run CCleaner. This seemingly silly little trick has worked for what is actually a weird Windows bug which can appear in many other situations other than running CCleaner.

 

With any luck, after you remove the blank disk it shouldn't happen any more.

 

Fingers crossed and let us know if it does the trick for you.

 

 

EDIT: Here's a previous similar example ...

 

http://forum.piriform.com/index.php?showtopic=33023&do=findComment&comment=196518

Share this post


Link to post
Share on other sites

I tried the blank disc thing several times and it still gives me the "no disc in drive D" warning,and i still have to reboot to get it working again.

I`ve been using Ccleaner for years on my XP PRO pc with no problems at all.

With my new Windows 7 pc,this problem started.All physical connections to the drive are real secure and the drive works properly.

I want to keep CCleaner,but i can`t tolerate having to reboot my pc everytime to get CCleaner to work again,so i installed SlimCleaner for now and there are no drive problems at all with that.

I`ve seen other people online have/had the same "no disc in drive" problem with CC by googling i the problem and no one seems to have a real fix for it.

I`m still keeping CC on my machine in case someone finds a fix for it but i won`t be using it until then.

If anyone has any other suggestions,please mention them.

Thanks

Share this post


Link to post
Share on other sites

It's a very old Windows bug, it's just that some software such as CCleaner, etc., will reveal it.

 

You could also try to reboot to see if it goes away (useful if you always have your computer running). Or shutdown, and then start your computer.

Share this post


Link to post
Share on other sites

It's a very old Windows bug, it's just that some software such as CCleaner, etc., will reveal it.

 

You could also try to reboot to see if it goes away (useful if you always have your computer running). Or shutdown, and then start your computer.

I tried rebooting/shutdown also,still get the " ccleaner.exe no disc in drive D" message after playing a cd in my D drive and it freezes it, and i have to reboot to get it working again.After i click "restart",windows asks to forcefully shut down "ccleaner.exe" and i click yes,then it will restart.

Might be a windows bug,but i have "no" "no disc in drive" problems at all with Slimcleaner.

Share this post


Link to post
Share on other sites

I deal with it all the time immediately after burning a disc, where using something like CCleaner, etc., reveals it, and open My Computer can cause it to freeze for several seconds to maybe 1 minute for which one has to be patient and wait for it to unfreeze and then reboot for it to go away.

 

CCleaner had something done in an update I've noticed where if going into the Secure Delete settings it detects the drives, I don't know if that also exacerbates it on your computer causing an issue.

Share this post


Link to post
Share on other sites

Yeah,i just opened CC and went into the "settings" category and you`re right,it detects the drives,but it detects the floppy drive and both my hard drives only.

Just to note,i have 2 optical drives, the cd drive is "D",and the dvd/cd drive is "E".

I noticed i can run a cd or dvd in the "E" drive,then run CC and it runs ok--"no" "no disc in drive" problem at all.

It`s just when i play a cd in the "D" drive and then run CC is when in get the  "no disc in drive D" problem.

I`m still trying to figure a fix for this when i have time since i like CC better than Slimcleaner,even though Slimcleaner runs fine and does "not' give me any no disc in drive problems at all.

Slimcleaner has some added unnecessary bloatware i don`t like.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...