Jump to content
CCleaner Community Forums

[4.09.4471] Minor cosmetic system tray tooltip bug


DevlinSyde

Recommended Posts

If I have previously enabled the option "Minmize to System Tray" and I run CCleaner using the /AUTO switch, initially hovering the mouse over the system tray icon will display a tooltip with the percentage complete as it runs silently.  As soon as I double-click the system tray icon to bring up the GUI and re-minimize it back to the system tray, hovering the mouse over the system tray icon will omit the percentage complete.

 

Steps to reproduce:

0) Make sure you've dirtied up your system quite a bit with Internet cache, Recycle Bin items, etc... for the sake of this example.  It's probably a good idea to have "Secure Wipe" enabled too just to slow all this entire process down to see what's going on.

1) Open CCleaner and make sure "Minmize to System Tray" is CHECKED.

2) Close out of CCleaner completely.

3) Open up cmd.exe and type: "%ProgramFiles%\CCleaner\CCleaner.exe" /AUTO

4) Hover your mouse over the system tray icon and it should display "CCleaner (Cleaning... N%)" (N = percent complete).

5) Double click on the system tray icon to bring up the GUI.

6) Minimize the GUI back to the system tray.

7) Hover your mouse over the system tray icon and it displays "CCleaner (Cleaning...)"

 

Intended result:

The tooltip should retain, "CCleaner (Cleaning... N%)" after displaying the GUI & re-minimizing it to the system tray.

 

Actual result:

The tooltip doesn't retain the percent completed after displaying the GUI & re-minimizing it to the system tray.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...