Jump to content
CCleaner Community Forums
switchs

failed to enable/disable startup item:access is denied

Recommended Posts

So I just updated to the latest ccleaner and when I went to try to disable some things from startup that popped up from new updates/installs I got this error message failed to enable/disable startup item:access is denied.

 

Any suggestions how to fix it? oh and I'm on Windows 7 if it matters.

Share this post


Link to post
Share on other sites

is your user account an Administrator or Limited level?

try starting CC with Run as Administrator

have you tried disabling the same entry using MSCONFIG?

Share this post


Link to post
Share on other sites

not confirmed here.

running Win8.1 Pro 64, CC v4.07

can enable/disable fine.

 

@switchs gave the impression this only started happening with the latest version, but @hpower1, you are saying it was even happening before that.

 

Uninstall/reinstall doesn't work, installing older version doesn't work.

 

i was going to suggest a Permission issue in the Registry, but that is doubtful since MSCONFIG works.

BTW, have either of you run the Registry cleaner in CC?

if so, and if you made a backup, have you tried restoring to before the registry clean?

Share this post


Link to post
Share on other sites

So I dug around other forums, got an idea. I knew it was something recent that had to have done it. Found it. Avast. New version I think is version 9. That breaks this function for ccleaner.

Share this post


Link to post
Share on other sites

it would be nice if @switchs gets back with his AV software ?

Share this post


Link to post
Share on other sites

The same issue happens to me, and I think I can help because I know what causes it.

 

It happens when I click “Open in RegEdit...” on any “Startup” key in CCleaner.

 

Then Regedit opens and says something like the key can't be opened. And no matter what I do, since then I can't open the key unless I reboot (haven't tried it yet, but I guess and hope it will work OK if I reboot!). And also can't enable/disable or delete any key on Startup in CCleaner.

 

So the bug starts with that “Open in RegEdit” command...

 

Please, fix it! CCleaner is such a wonderful program...

Share this post


Link to post
Share on other sites

Even with a reboot, the Run key has no other values than the default one, while CCleaner and msconfig show the startup keys. It also gives the acces denied error on CCleaner when trying to enable/disable or delete any startup key, even whithout hitting “Open in RegEdit”.

 

It happens on two different computers with Windows 7 (x64 Ultimate SP1), and using CCleaner v. 4.05.4250 and also the latest version (and I guess with all previous versions, really...).

 

I hope the Regedit didn't get corrupted...

 

This bug needs to be fixed soon! Should we post a bug report? -_-

 

Best regards.

Share this post


Link to post
Share on other sites

Yes, I'm using avast! Free Antivirus 2014, but when I open Regedit (CCleaner closed), even when the error popup message isn't displayed, I can't see any key on Run... :S

 

Never happened to me something like this when using CCleaner or Regedit. Maybe it's a bug on avast!, or maybe CCleaner is buggy on that Open in RegEdit command... :S I don't really know, but I'm glad I can help somehow reporting the problem. It's pretty annoying to be unable to manage startup keys... I don't like to mess with msconfig. That's why I use CCleaner, to avoid going to all the subkeys on Regedit.

 

Best regards.

Share this post


Link to post
Share on other sites

the problem would be with avast

it seem avast self defense protected more than it should

if you want to use ccleaner's startup, you need to first disable avast self defense > use ccleaner > re-enable avast self defense

it is not advisable to do that incase you forgot to re-enable it back and come back here with another problem with malware

so it is at your own risk or you can use msconfig which is safer than disabling avast self defense

you can compare ccleaner's startup entries with msconfig to choose which one to disable

:)

Share this post


Link to post
Share on other sites

Disabling avast! selfdefense module one can manage without a problem the keys in Startup, indeed. How it's possible that avast! selfdefense module affects all startup keys? :S It's nonsense, and that didn't happen in the past.

avast! is so buggy (or at least weird) lately, but I think CCleaner has some little bug with the issue as well...

Anyway, I hope the problem is solved soon, because I don't want to disable the selfdefense everytime... It's easier to go to the key in the Regedit directly...

Still love CCleaner and I hope it keeps as good or even better. Same goes for avast!, which lately isn't doing as good as it used to, even though it's still nice...

Best regards.

PS: The problem occurs on Windows 8.1 when using avast! as well.

Share this post


Link to post
Share on other sites

I have avast! 9.0.2011 and the latest CCleaner and still can't do anything with the avast.ui startup key. I don't have any other program there (I keep my system superclean! :D). I'll try it with another computer with avast! and Windows 8.1 (mine is Windows 7 SP1).

Best regards.

Share this post


Link to post
Share on other sites

Avast is a nightmare. Just use security essentials if you have xp or seven or windows defender if you have windows 8. Much more lightweith on resources, and much mor problems free and it does the job perfectly.

Cheers.

Share this post


Link to post
Share on other sites
Avast is a nightmare. Just use security essentials if you have xp or seven or windows defender if you have windows 8. Much more lightweith on resources, and much mor problems free and it does the job perfectly.

Cheers.

Really not that helpful in regards to the question ... just sayin'

Share this post


Link to post
Share on other sites

Really not that helpful in regards to the question ... just sayin'

Ok. I am sorry. But, i wasnt trying to help in a "tecnical way", since everyone said that avast was the problem, i merely made a sugestion to quicky solve the problem.

Like when you cannot take coffe with sugar then you simply take it with sweetener....just sayin....

Sorry again, don t speek no more.

Share this post


Link to post
Share on other sites

I'm getting the same message with the latest version of CCleaner. A couple different variables in my case than those previously described.

 

I'm running Win7 64-bit with Norton Internet Security (not Avast). - so that's different

 

The startup item I'm trying to disable is in Chrome, not Windows Startup - so that's different

 

Anyone know the Chrome equivalent of MSConfig so I can test out the ability to disable using that vs. using CCleaner?

I'll post my results.

 

Thx

Share this post


Link to post
Share on other sites

I'm getting the same message with the latest version of CCleaner. A couple different variables in my case than those previously described.

 

I'm running Win7 64-bit with Norton Internet Security (not Avast). - so that's different

 

The startup item I'm trying to disable is in Chrome, not Windows Startup - so that's different

 

Anyone know the Chrome equivalent of MSConfig so I can test out the ability to disable using that vs. using CCleaner?

I'll post my results.

 

Thx

the "Chrome" only allow you to enable or disable extension, not program like MSConfig

this is different from OP so you might need to create new thread regarding this problem

it is better if you can provide a screenshot of your problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...