Jump to content
CCleaner Community Forums
RobZigger

CCleaner stopped working under Mavericks

Recommended Posts

I'm getting an error message that states:

 

Your operating system is not supported.

Share this post


Link to post
Share on other sites

The fix to CCLEANER for OS X 10.9 should be rather easy for the Piriform.

 

Only needed change is the max version limit test of OS X from 10.8 to 10.9 in the program. Should be a simple change.

 

The current CCLEANER logic/executable will work with 10.9 OS X. Check for yourself -- simply change OS version file on your Mac to test.

 

The text file to change is "SystemVersion.plist" in the System\Library\CoreServices folder. Change the "10.9" string to "10.8.5". Save the file and CCLEANER will now run.

 

***The issue is that you have to change it back to 10.9 for other programs in OS 10.9 to function.***

 

Piriform just needs to change the version check from 10.8 to 10.9 in there app and the ccleaner program will work. They can always tweak the progeam later for 10.9 enhancements.

Share this post


Link to post
Share on other sites

How do I transfer my pro licence from the version I bought in the App store to the one I have downloaded from the piriform website?

Share this post


Link to post
Share on other sites

Hi Loz, and welcome to Piriform.

 

Is the version you've downloaded from Piriform a later version than the one you have installed from the App Store, and have you actually installed the Piriform version?

 

Not having a Mac I would have thought the licence (if still current) would automatically be carried into the new install wherever it's downloaded from.

 

If you get no further input better than that, let me know what you've done and if necessary I'll contact the devs for an answer.

:)

Share this post


Link to post
Share on other sites
 I would have thought the licence (if still current) would automatically be carried into the new install wherever it's downloaded from.

 

It wouldn't. Mac apps downloaded through the store are entirely self contained for security (and simplicity) reasons.

Share this post


Link to post
Share on other sites

In that case can I suggest you (Loz) contact Piriforum support direct with your issue, which should be the quickest way to get a resolution.

 

Piriform Support

 

I could mention your issue myself but it's possible they would ask me to pass on the same suggestion to you, which would obviously take more time.

 

Hope that helps, and thanks Shane for your input.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...