[[Template core/front/global/favico is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]] Jump to content
CCleaner Community Forums

IE10 on Win 7 bug


Samal48

Recommended Posts

After updating to IE10 on Win 7 certain websites (ex. Bing, Twitter, others) will not load properly after running Ccleaner. This problem did not occur on IE9. After trying everything I could think of the only solution is to delete cookies and data under Internet Options. After that the only way you can use Ccleaner without the error reoccurring is if you uncheck everything under internet explorer on it. I tried leaving cookies checked since I can delete everything else with Internet Options and keep my exceptions but the error still occurred.

Link to post
Share on other sites

I tried just unticking Index.dat first. Then unchecked one more at a time until only cookies remained but the errors still occurred unless everything was unchecked. It's not a huge inconvenience as Firefox works fine but I prefer IE and the problem was not present on IE9. It was actually a relief to finally pinpoint Ccleaner as the cause as I tried a ton of different things before that.

Link to post
Share on other sites

More info onto my last post as it relates to Win7 IE10

 

It looks like in IE10 the index.dat files are now named 'container.dat' instead, and I can see in the half dozen places where there was an index.dat file it was 'replaced' with a container dat ...interesting. Also I notice that that in CCleaner IE tab right clicking on the index.dat listing, and clicking the Analyze button, no data shows up for it anymore.

 

I noticed to edit my message here properly I had to put this Piriform website in Compatibility Mode in order for things to work right.

My bank works better in Compatibility Mode too...

...I can't tell if the problem is a Compatibility Mode issue with all these websites as they relate to working properly with IE10 - I just don't know it's too soon to tell, yet.

 

I don't think ..at this point with CCleaner v3.28.1913 the index.dat rather now called container.dat files, are getting cleaned anymore!

Link to post
Share on other sites

It looks like in IE10 the index.dat files are now named 'container.dat' instead

In the past Microsoft were not above using Open Source software.

I wonder if they have also borrowed from Firefox the use of the plugin-container,exe.

Link to post
Share on other sites

When it comes to Windows 7 and IE10, is it correct to assume that the coders are aware that it's not currently cleaning IE10 properly and are working on it? ...and when they are done the goal is that CCleaner will soon be able to clear all areas of IE just as thoroughly as it did before, especially! clear all the areas that the previous index.dat files reign took care of but now clean them within their new name and environment. Are those assumptions correct ?

 

In the meantime is okay to use CCleaner as long as we uncheck all the boxes under the Internet Explorer header?

 

Thank you much.

Link to post
Share on other sites
  • Moderators

Jessie, that assumption can be made, based on the fact that the developer team reads all threads (though next-to-never comments). While we may see the fix in .29 I, and no one else either, have no inside information on the actual goings on.

Link to post
Share on other sites
  • 3 weeks later...
  • Moderators

as I stated in that thread

this is actually a long running bug in Internet Explorer, it occurs with many cleaners. IIRC it has to do with index.dat corruption, or history can't remember and maybe has to do with IE being set to delete temporary files after last window is closed. Try to uncheck index.dat in ccleaner and if that doesn't work uncheck history.

Link to post
Share on other sites

After updating to IE10 on Win 7 certain websites (ex. Bing, Twitter, others) will not load properly after running Ccleaner. This problem did not occur on IE9. After trying everything I could think of the only solution is to delete cookies and data under Internet Options. After that the only way you can use Ccleaner without the error reoccurring is if you uncheck everything under internet explorer on it. I tried leaving cookies checked since I can delete everything else with Internet Options and keep my exceptions but the error still occurred.

This problem is not fixed completely in Cclean 4.00
Link to post
Share on other sites
  • Moderators

touch you made that clear in your last three, posts. It is frowned upon to post as your are (triple posting as of now).

please read my explanation in the post right before your first of this batch of three.

Link to post
Share on other sites

Yes it seems I spoke too soon. While most of the old sites seem to work after the 4.0 release, I have noticed a few new problems. Bing will only load correctly after using CCleaner when there is a stationary background. When it has a moving or video background, it will not load. A few live scoreboard sites will also not work correctly. It seems it is usually adobe flash player or a similar application that has the problem loading.

Link to post
Share on other sites

Yes it seems I spoke too soon. While most of the old sites seem to work after the 4.0 release, I have noticed a few new problems. Bing will only load correctly after using CCleaner when there is a stationary background. When it has a moving or video background, it will not load. A few live scoreboard sites will also not work correctly. It seems it is usually adobe flash player or a similar application that has the problem loading.

I think there is a problem with "cookies and website data" .website will be load normally after delete cookies and website data by IE 10
Link to post
Share on other sites
  • 3 weeks later...
  • Bug Fixers

Hi everyone,

 

We are sorry to hear that you are having problems with CCleaner and IE10.

 

Could someone provide more details about what is not really working with these sites? The more details the better so we can try to reproduce in house and come up with a solution.

 

Thanks for your help and support!

Link to post
Share on other sites

On Twitter, when you click on a tweet in the timeline nothing happens. You cannot expand it or anything as it is nonfunctional. Also, the who to follow and trending boxes in the left column never load and don't show up. On Bing, if there is a moving or video wallpaper that day the page will never load and it will just be blank grey. Both of these and most of the other IE10 problems were fixed by the CCleaner 4.0 release but since the IE10 update a few weeks ago these have reemerged and were not fixed by the newest CCleaner release. I cannot speak for the Weibo problem or other sites as once I noticed these two problems reappear I just quit using CCleaner for IE again. I understand that there might always be some small problems or inconveniences with cleaner programs but these are some major websites that are simply not functional after running Cleaner.

Link to post
Share on other sites
  • 3 weeks later...

I first noticed the problem on Facebook. I carried out my regular clean up using CCleaner and all was okay until I checked my Facebook messages and they would not show. The only way I could get them back was to completely reset IE10. At the same time I also made sure that everything else was up to date including Java, Adobe Flash, Shockwave and Air just for good measure. This made no difference. I also used CCleaner on two other machines with IE10 and logged into Facebook and the problems were still there. It's just too much hassle using CCleaner now so hope that a fix will soon come out as it is the best cleaner ever and I miss using it!

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...