Jump to content

Parameter is incorrect


Recommended Posts

I have a 16 GB Micro SD card from my phone that just stopped working and said it was empty, I know there's a thousand pics on it ,nothing I tried would bring it up. So I removed it and got the free version of recuva, went through the wizard and selected what I thought was right , and it said the parameter was in correct, I'm not sure what that means, but I need help...currently running windows vista.


Thanks Jim

Link to comment
Share on other sites

  • Moderators

This is an error that seems to comeup now and again with no clear answer as to what causes it.





Have you tried it in a friend's phone?


Have you tried right-clicking on Recuva and selecting 'run as administrator'?


Support contact




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.