Jump to content

High CPU, Non-recovery from Mini SD


Recommended Posts

I have been trying to recover some files I accidentally deleted on my phone's mini SD card. Have tried directly connecting the phone as well as using a mini-sd to SD adapter to use in computer. Recuva finds stuff, reports it all as intact and good for recovery, but If I choose a file/s to recover it simply hangs on the screen shown below all while consuming 100% of CPU. Cancelling doesn't change a thing. Same thing happens if I preview. I have to kill the Recuva.exe process manually


I have left this for hours with absolutely no progress whatsoever. Debug did not produce a dump cos of forced termination, only a txt file.


Recovering to a separate drive, not back to the SD card.OS is Win7 64bit, and tried both 32 and 64bit versions of recuva (version 1.43.623)


Any ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.