Jump to content

Cannot initialise SPC dll


Recommended Posts


I hope somebody help me with this issue .

I used specy before and worked just fine .

now I have this problem , message error showing


Operating system

MS Windows 7 Ultimate 32- bit SP1


Cannot initialise SPC dll


Cannot initialise SPC dll


Cannot initialise SPC dll


Cannot initialise SPC dll

Hard drives

Cannot initialise SPC dll

Optical drives

Slimtype DVD


High definition audio

Link to comment
Share on other sites

  • 2 weeks later...

Got exactly the same problem but on an XP¨SP3 32-bit laptop. This happened all of a sudden since up to now Speccy has been working without fail and was properly updated to v.1.18.379. The failures are preceded by an error message saying: "CPU dll init failed (error 8). Some information will not be displayed".


What is to be done?



Link to comment
Share on other sites

What I can add to my message is that:

- Speccy on my Windows 7 64-bit machine works without a hitch.

- I tried to uninstall Speccy completely (with Revo uninstaller) from my XP machine then re-install it - to no avail.

- Re-booting doesn't work either...



Link to comment
Share on other sites

  • Moderators

Hi faycal and haku, and welcome to the forum.


I haven't ever seen a specific fix for this issue (unless I missed it). I've had it happen on my XP machine, and then for whatever reason, it stopped happening without my doing anything.


@haku You've had this issue before in May this year and you fixed it ...




... has anything changed since then such as a change of security software?


I could link you to many other threads regarding this problem, but they all basically suggest a small number of possibilities.


Rebooting has fixed it for some, as has the following ...


Commodo sandbox was blocking it.




REinstalling Speccy has fixed it for some. (see also haku's topic above)




Overclocking and messing with the BIOS can cause it to happen ...




Outpost Firewall can cause the issue ...




Even an overheating computer has been mentioned.


Also have a look here ...




The devs have looked at this in detail before, and I'm sure they'll be taking note of this thread as well.

Link to comment
Share on other sites

  • 1 month later...

Try a program called "Windows Repair" (www.tweaking.com) and make sure you - at least - tick the box called "Repair WMI". WMI is used to pull up A LOT OF info from one's computer system. The program can fix A LOT OF (not all !!!) other computer problems as well. If it helped you to get rid of the "Cannot initialise SPC dll" error then post a new reply in this thread. Or send the author (Piriform forum nickname: SMC1979) a "thank you" PM.


Or post a "Thank you" post on the www.Tweaking.com forum.

System setup: http://speccy.piriform.com/results/gcNzIPEjEb0B2khOOBVCHPc


A discussion always stimulates the braincells !!!

Link to comment
Share on other sites

  • 1 year later...

I have looking for a solution for years on this.


For me I found my problem, Which is Core Temp.


It must take a resource. If I uninstall it, Speccy works. If I stop CoreTemp(1.6 now) in processes, I can get all the Speccy specs.


However, I have about 7pc's, and on some of them Speccy always worked, even with CoreTemp running.


True in w7 and XP. I dont have a Vista or w8.



So, I dont know how many of you have CoreTemp, but perhaps another CPU monitor can cause the Error8 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.