Jump to content

Unsuccessful undelete


Recommended Posts

i have a serious problem attempting to undelete movies (and photos) from my movie camera. i have used google (trying to find suggestions/help) extensively to no avail.

history - i have over 10 years of experience with digital camera imports to my desktop. for my convenience (not so convenient today), i have always selected ‘delete after importing’. it worked fine on 7-8 different computers and 7-8 different cameras over those 10 years, including the current one. but not this time. the import appeared to work, but no pictures or movies were to be found on my hard drive. sure enough, the ‘delete after import’ worked just fine. so, i started looking to undelete.

the camera is an oregon scientific atc9k hd all terrain waterproof video action camera with a 32gb mini-sandisk card.

i found some online software to perform the undelete for ‘free’. i looked at http://ntfsundelete.com/ . it looked promising, but it proved to not be free and i wanted to focus on that route. i then found others that all said they would perform the undelete.

first try:


this appeared to recover my photos reasonably well, but all movies that were recovered failed. when trying to play on wmp, i get an error message “windows media player encountered a problem while trying to play the file. when i play on itunes, itunes crashes, no error message.

second try:


with this my movies all appear to be recovered, but when playing on wmp, i get the whole duration of the movie with a completely black screen - no sound, no images. when i attempt to ‘open with’ itunes, i get a trip to the itunes store, but nothing plays. if i import the movie into my library and then attempt to play it, itunes plays static and a single frame of the movie for 1-2 seconds and then itunes crashes.

third try:


also with this my movies all appear to be recovered, but when playing on wmp, i get the whole duration of the movie with a completely black screen - no sound, no images. when i attempt to play on itunes, i get a trip to the itunes store, but nothing plays. if i import the movie into my library and then attempt to play it, itunes plays static and a single frame of the movie for 1-2 seconds and then itunes crashes.

fourth try:


same results. many photos restored, but about half were partials. all movies that were restored play black screens (for the original duration of the movie clip, just no sound and no picture).


i keep thinking i am close to getting my movies recovered, but perhaps i am merely delusional. do i need to try a different undelete? try a different program to play the movies? find a program to manipulate the movies (repair the recovered file) such that they can then be played? should i search harder on my hard drive to find the imports that mysteriously disappeared?

since nothing has been done with the camera since the import performed the delete function, i am surprised that i am having so much difficulty with the undelete. that is, nothing has been written on the memory card.


i would attach a copy of an unsuccessful movie undelete, but even the small movies are 2mb+, some are even 633mb, but none small enough for the 1.95mb limit.



Link to comment
Share on other sites

wmp gives a black screen when you try to pay a recovered file.

could wmp be broken ?

i.e. does it now give a black screen when playing back one of your videos that previously imported from the same camera ?

Link to comment
Share on other sites

thanks for the idea, but i am certain wmp is not broken. not only can i play prior movies imported from this camera, i can play any video on my desktop from wmp just fine. except i can not play any of the restored videos that were undeleted.


the whole things seems so strange to me. this is my first experience, ever, in working with undelete (on a memory card or hard drive or whatever). i am 64 years old and was working with computers in the 60s (ms computer science 1971) and that defined my entire career. of course, that was way before pcs and i am far from a pc expert.


it seems like undelete would be binary. it would work or not work. no other choices. to sort of work, but give me partial photos (in some cases) and full photos in other cases; and 100% of the movies that were recovered not being playable - makes no sense to me. i guess there is just a whole lot more going on in the delete and undelete process than i realize. but, what it is, i have no idea.


i am also shocked that wmp gives black video and silence, while itunes gives loud static and a brief visual image of the actual video and then crashes. strange stuff.

Link to comment
Share on other sites

if itunes can see something different to wmp perhaps other players (eg vlc) may be even better.


it is possible files were copied to your desktop and may have appeared briefly on your hdd.at about the time the mini-card was deleted.


the black files you have retrieved - did you recuva them from :-

your desktop (somewhere in c:\)

or from your intended archive destination drive,

or from the camera mini-card

all three above are possibilities and it might help if you identify which you have attempted


i will now leave it to those with more experience of recuva to advise you on your next steps.

Link to comment
Share on other sites

RE: my 'recovered' files - I got them from the camera mini-card.


When I did the import (from Windows Live Photo Gallery) I saw a full screen of icons representing what I had just imported. However, I then went to import more - from my iPhone. Those were all showing as icons (and deleted from my iPhone) after that import. Then, when I went to look at my prior import, there was no folder to be found - I would love to look for them on my hard drive, but I have no clue where to look!!! Import has always created new (date) folders in My Pictures. But, there was no folder there for the missing pictures/videos. Thus, my attempt to undelete them from my camera mini-card.

Link to comment
Share on other sites

I have no experience or knowledge of Windows Live Photo Gallery.


Perhaps you had a successful import from the camera, but a glitch during the transition to the iPhone import caused a failure to commit onto HDD

or perhaps your unspecified Windows is Vista or Windows 7 in which case when you are able to see files the often do not exist where you think but somewhere else,

and if a special link or reparse point is damaged you have to look elsewhere to find them.

Just possibly Windows Explorer might find them if you look in the correct place - but I do not know where that might be.


What is your operating system - it may help those who can advise you.

Link to comment
Share on other sites

  • 4 weeks later...

I thought I would provide an update and closure - been out of the country awhile and not focusing on this.

1 - I loaded VLC and was barely more successful at playing the recovered videos than I was with iTunes or wmp. Not a lot of difference, but slightly better. I'm still stunned about the results of my 'undelete' - being a computer professional from 1971 - 2004 (since retired), I am WAY outdated, but I do have some basic understanding about file structures and computer software internals. It would seem to me that the undelete would work, perfectly, or fail completely. The 'partial' effect that resulted from my undelete is hard to grasp. Oh well, it is what it is.


But, the 'good' news is that I have the photos and movies that I took. The problem - the internal date on the camera was a year off - 2011, not 2012. So, import stuck them in the 2011 portion of my Pictures directory and they went unnoticed for about a month. Later I stumbled upon them. I couldn't fathom how the import could have failed to work, because it always has and I saw the photos and movies on my screen before moving on to the next import. Anyway, I thought I would provide this happy ending to a saga that was very confusing to me and still is. That is, how can it be that undelete doesn't either work or not work, based on data over written or not over written - having taken no further photos, I thought the camera memory card would be untouched (except by the delete function after import).

Link to comment
Share on other sites

Recuva seems to NOT be working properly at all...

I work for a publishing compny and just deleted 160 PDF files out of a desktop folder as a test after purchasing this product.

Good thing I saved a copy of all these PDF files on my flash drive.

I started up Recuva, and selected "Deep Scan" after the initial scan detected absolutely nothing had been deleted *"?"*

After the 30 minutes that it took to "Deep Scan" a single small folder, this "Deep Scan" also returned "0" results...


Did I just pay $30 for software that does "Nothing"???

Anyone else performed an actual test to see if this software actually, and factually, works??


I have performed this "test" 3 different times, rebooting each time, and with a totally different file set each time... SAME RESULTS!!


- Jonathan

- Just Busted News

Link to comment
Share on other sites

  • Moderators

if you paid, you need to contact support as that was what you paid for (it's the only major difference between the paid and free versions)

on top of that every reboot and write to the drive DECREASES the chance of successful recovery, so after 3 reboots you may well have destroyed any chances with recuva or any other software to retrieve your files




Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)


CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

I have been told by an I.T. support man that the Desktop is the the most vulnerable place for any file that has NOT been deleted.

When it is deleted that will not prevent it being over-written.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.