Jump to content
CCleaner Community Forums

Ccleaner does not open


Recommended Posts

A few weeks ago, Ccleaner (v1.26.218 on Windows XP) wouldn't open. I posted the problem here (can't find that post now), and promptly got a solution

  • uninstall Ccleaner
  • restart Windows
  • reinstall Ccleaner

That resolved my problem - Ccleaner worked again, but I lost all my settings. I later got additional information on how to export Ccleaner's registry settings, which I did.

 

Today again Ccleaner stopped from opening. I uninstalled Ccleaner, rebooted, then reinstalled and restored the registry settings.

 

Unfortunately :( Ccleaner still won't open. Could it have something to do with the registry settings? Here is the contents of the REG file I exported.

 

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Software\VB and VBA Program Settings\CCleaner][HKEY_CURRENT_USER\Software\VB and VBA Program Settings\CCleaner\Options]"Language"="1033""UPDATEKEY"="2005-12-05 15:52:40""UpdateCheck"="1""CookiesToSave"="amazon.co.jp|amazon.co.uk|amazon.com|amazon.de|beta01.mail.com|beta02.mail.com|borland.com|brit.fbcusa.com|ccleaner.com|cincom.com|climateapps2.oucs.ox.ac.uk|cloudmark.com|cnn.com|com.com|dell.com|download.adobe.com|download.com|download.zonelabs.com|expedia.com|forum.ccleaner.com|forum.spamcop.net|forums.chef2chef.net|forums.dmoz.org|forums.net-integration.net|google.com|mail.com|mail.google.com|mail.google.com/mail|mailsc.spamcop.net|metropolis.japantoday.com|microsoft.com|mozillazine.org|neodigital.co.uk|neoplanet.co.uk|office.microsoft.com|passport.com|passport.net|paypal.com|simplyguides.net|sun.com|support.intel.com|support.microsoft.com|tagesanzeiger.ch|vmware.com|weatherunderground.com|web.archive.org|wunderground.com|www.adobe.com|www.adobeforums.com|www.cincom.com|www.climateprediction.net|www.cloudmark.com|www.diskeeper.com|www.download.com|www.ewido.net|www.executive.com|www.executivesoftware.com|www.fbcusa.com|www.global-dining.com|www.gol.com|www.google.com|www.hummingbird.com|www.ibm.com|www.intel.com|www.ipswitch.com|www.japantoday.com|www.lavasoftsupport.com|www.lookoutsoft.com|www.mail.com|www.mozillazine.org|www.olspamcop.org|www.paypal.com|www.simplyguides.net|www.tagesanzeiger.ch|www.wired.com|www.wunderground.com|www.zonelabs.com|yahoo.com|yourdictionary.com""MSG_CONFIRMCLEAN"="False""WINDOW_MAX"="1""(App)Temporary Internet Files"="True""(App)Cookies"="False""(App)History"="True""(App)Recently Typed URLs"="False""(App)Delete Index.dat files"="True""(App)Last Download Location"="False""(App)Autocomplete Form History"="False""(App)Recent Documents"="False""(App)Run (in Start Menu)"="False""(App)Search Assistant Autocomplete"="False""(App)Other Explorer MRUs"="False""(App)Empty Recycle Bin"="True""(App)Temporary Files"="True""(App)Clipboard"="True""(App)Memory Dumps"="True""(App)Chkdsk File Fragments"="True""(App)Windows Log Files"="True""(App)Old Prefetch data"="True""(App)Menu Order Cache"="False""(App)Tray Notifications Cache"="True""(App)Window Size/Location Cache"="False""(App)User Assist History"="True""(App)IIS Log Files"="True""(App)Custom Folders"="False""(App)Mozilla - Internet Cache"="True""(App)Mozilla - Internet History"="False""(App)Mozilla - Download History"="True""(App)Mozilla - Cookies"="True""(App)Mozilla - Saved Form Information"="False""(App)Adobe Acrobat Reader 7.0"="False""(App)Google Toolbar"="False""(App)Windows Media Player"="True""(App)Real Player"="True""(App)Quicktime Player"="True""(App)Paint Shop Pro 7.0"="False""(App)Office 97"="True""(App)Office XP"="True""(App)Office 2003"="False""(App)Macromedia Flash Player"="True""(App)MS Management Console"="True""(App)MS Wordpad"="True""(App)MS Paint"="True""(App)SpyBot Search and Destroy"="True""(App)Ad-Aware SE Professional"="True""(App)Microsoft Visual Studio 6.0"="False""(App)IsoBuster"="True""(App)WinZip"="True""(App)Sun Java"="True""(App)Windows Movie Maker"="True""(App)RegEdit"="True""(App)ZoneAlarm (Logs)"="True""(App)Microsoft AntiSpyware"="True""(App)Ewido Security Suite (Log)"="True"

 

Link to post
Share on other sites

I uninstalled again, rebooted and reinstalled. This time I did not load the saved REG file. Ccleaner starts just fine.

 

Next I restored the saved registry entries; Ccleaner won't open any more. When checking the task manager, it just sits there doing nothing.

Link to post
Share on other sites
  • Moderators

The other time it happened you posted about it here:

http://forum.ccleaner.com/index.php?showtopic=3385

 

Since it seems to be a registry related issue that nobody except the developer will probably know about, PM the CCleaner developer MrG and point him in the direction of both threads you've started about the issue.

The first one: http://forum.ccleaner.com/index.php?showtopic=3385

This one: http://forum.ccleaner.com/index.php?showtopic=3468

Link to post
Share on other sites

Thank you for your reply. I just ran Ccleaner with the /debug switch. It appeared that nothing was happening at all, and I was just going to report that, when I got this pop-up

 

ccleaner-msg.gif

 

After this Ccleaner opened normally.

Link to post
Share on other sites

What is even more strange is that after running Ccleaner with the /debug option, and getting the message above, it now opens normally every time.

 

But anyway, I am still interested what that message means, and what Ccleaner was trying to do. Update check, perhaps?

 

 

P.S. I have now disabled 'Automatically check for updates'.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...