Jump to content
CCleaner Community Forums
David_L

wifi problem

Recommended Posts

Sorry if this isn't a software problem, I'm not sure. I have a Windows 7 64 bit Toshiba laptop which suddenly refuses to connect to my work's unsecured wifi. I can connect fine to my secured wireless router at home and to other unsecured wifi hotspots in town (Starbucks, public library, etc). Toshiba tech support has been zero help, so I'm turning to y'all. My wifi adapter sees available networks at work, but won't connect. I get the yellow triangle with the exclamation point through it over the status bar icon in the task bar and when I click on it it says I'm connected but also says limited access and/or no internet access. I didn't change any settings to cause this that I know of, and like I said this just suddenly began happening about 4 weeks ago. I spoke to our IT dept and they said they haven't changed anything with their equipment around that time, and I can't really ask them for advice since this is a personal laptop. Also, I have an XP Dell that connects just fine and coworkers with various systems that connect just fine as well. I thought maybe the internal wifi adapter was shot so I hooked up an external USB one and it behaves just like the internal one. Sees lots of available networks, says it's connected but with "limited access". I downloaded a program called Xirrus and at home, where I can connect, everything looks good. But at work this is the info I get:

 

Wireless

SSID: GuestNetwork

BSSID: Cisco - Linksys:2F:CC:BC

Channel : 11

Signal: -58 dBm

Mode: 802.11g

Addresses

MAC: 00:23:15:59:DE:90

IP: 169.254.232.225

DNS: N/A

Gateway: N/A

External IP:

 

So I know the "N/A" under DNS and Gateway is a bad thing and I think the "IP: 169.254.xxx.xxx" is a bad thing too (at home it's like 192.xxx.xxx.xxx) and I think the External IP being blank is bad. I really don't know anything about wifi, so what am I looking at and what should I be trying to look at on my laptop to fix it? Things I have done with no success are restore the laptop to factory new conditions, disabled the Windows firewall, uninstalled and reinstalled the wifi adapter drivers, the drivers are up to date, disabled and reinabled the adapter, tried connecting in Safe Mode With Networking, bang head against wall, pull out hair, etc. All with no luck. Any ideas? Thanks.

 

EDIT: I've also done the ipconfig /release, ipconfig /renew, etc as well.

Share this post


Link to post
Share on other sites

What do you see (at work) if you open a cmd prompt and type

 

ping google.com

 

then press enter?

 

Wireless Zero Configuration set to auto in services?

Share this post


Link to post
Share on other sites

A broken connection usually results in weird IP addresses like 169.254.232.225 in this mode you'll find that ipconfig.exe or arp.exe are ineffective.

Also your IP department claim they've done nothing to their equipment and yet it would appear your machine is being denied access maybe by mac address or computer name.

 

A few things to try out:

 

- update your Intel wireless drivers via the Toshiba driver site.

 

- open the wifi tray icon and use the "Repair" option

 

- open device manager, disable wifi, enable wifi and rescan networks

 

- open system properties and change your computer name

 

- change your wifi mac address (spoofing)

 

- try a bootable Live Linux CD like Ubuntu to see if wifi works.

 

Richard S.

Share this post


Link to post
Share on other sites

I spoke to our IT dept and they said they haven't changed anything with their equipment around that time.

They are guilty of change if they allow Microsoft Security Updates.

 

Since February I have allowed updates on 2 occasions.

Twice I had to restore an earlier partition image to neutralise the damage.

 

Disabling unsecured wireless access to the company network is definitely appropriate,

the only surprise would be if it was Microsoft that took effective action and not third party Malware/Firewall protection.

 

see

http://www.dailymail.co.uk/sciencetech/article-1323310/Google-admits-Street-View-cars-DID-emails-passwords-computers.html

 

You may have neither inclination or ability to hack into company records,

but passers by may enjoy free internet access when they find it.

 

Hackers could have even got at Google's data base, seen your open wifi, and deliberately driven by with a car load of equipment to do bad things.

Share this post


Link to post
Share on other sites

They are guilty of change if they allow Microsoft Security Updates.

 

 

 

Don't agree Alan. A vast number of infections and exploits occur because of unpatched systems

Share this post


Link to post
Share on other sites

Don't agree Alan. A vast number of infections and exploits occur because of unpatched systems

Actually I am with you on that.

I approve of companies keeping their systems patched,

but I am pointing out that patches sometimes go wrong,

and this is why some administrators test patches on a non-production machine to see if their applications survive before they deploy to production machines.

 

In this case perhaps the patch actually went right and plugged a hole which seems to have been left wide open by I.T.

 

My suspicion is that if David thinks they will not be willing to advise him how to connect his personal computer,

then it is unlikely they have given (or denied) authority to his specific MAC address.

 

i.e. The man in the street has/had the same wifi access as David,

and some of those strangers have evil intentions and capabilities.

Share this post


Link to post
Share on other sites

When I ping google.com it says ping request could not find host google.com. Please check the name and try again.

 

Not sure if I'm looking in the right place for Services, but if I go to the task mgr and click the Services tab there's a button that says Services and a list pops up but there's no Wireless Zero Configuration. There is a Wireless AutoConfig with Startup Type Manual and a Wirelss PAN DHCP Server with Startup Type Manual.

 

I've got the latest drivers off the Toshiba site.

 

I've ran the Windows Network Diagnostics and it says contact the network admin if at a hotspot, otherwise reset the router or modem. Then says Wireless Network Connection doesn't have valid IP configuration.

 

Not sure how to spoof MAC.

 

Changing computer name didn't work.

 

I work at a hospital and we offer free wifi to our patients and guests, and staff for personal use. No password required, it's an unsecured network. I know others with Windows 7 systems that connect just fine, as well as XP machines and smart phones. People were using the wifi today. I'm sure our IT crew keeps things updated and patched. I do the same with my laptop. On the Toshiba forum one guy suggests turning off Automatic Windows Updating after restoring the laptop to factory new settings, that probably a Windows update is the problem. But my laptop refused to connect even after restoring to factory settings. I really feel awkward about calling our IT dept and asking for help for my personal computer. It'd be like calling down to the ER and asking for free medical advice when I have a sore throat. The silly thing works perfectly everywhere else in the world. Just not at my workplace. Maybe someone is telling me I should work rather than surf the web. Or buy an HP or a Dell maybe.

Share this post


Link to post
Share on other sites

Don't feel awkward about asking your IT dept for a bit of advice, if free wi-fi is provided for staff then you have nothing to lose (and everything to gain) by going cap in hand and asking for their help.

 

Sorry about saying Wireless Zero Configuration , it's called Wireless AutoConfig after xp.

 

It is started I take it?

 

http://www.home-network-help.com/wlan-autoconfig-service.html

Share this post


Link to post
Share on other sites

Please try the Live Linux boot CD option this should help determine whether Windows is to blame or the wireless router at the hospital.

 

Richard S.

Share this post


Link to post
Share on other sites

No, the Wireless AutoConfig doesn't say "started" under Status. It does say "manual" under Startup Type. Should I change that to "automatic"?

 

I will try the Live Linux CD. Is this one, the 64 bit Windows one, a suitable one? http://www.ubuntu.com/download/ubuntu/download

 

I will contact our IT dept. But since this is a problem with my own personal computer, and since I'm at work and supposed to be doing other things, I really can't spend too much time fiddling with it. If only I could walk into their dept, drop it off and say "here, make it work". :D

Share this post


Link to post
Share on other sites

Success!! I boot off the Linux Ubuntu CD and it connects just fine. So there's some hiccup between my Windows 7 and the hospital's routers, no? I'm on the first floor and I bet they heard me "WHOOP" all the way to the 6th floor when it connected. So I'm thinking I'll just install Linux, the CD is super slow, and use Linux while at work. Is one version of Linux better than another? What do you recommend?

 

I know the issue isn't really fixed, if you have any more suggestions to fix the actual problem I'll gladly try them, but at least I have a work around now. I've been fighting this for 4 weeks now. Thank y'all so much!!

Share this post


Link to post
Share on other sites

Why don't you try running a Linux distro from a USB stick? You won't suffer the slowness of a CD.

 

Lots of recent discussions on here, for example Ubuntu and Puppy. Both well established, with lots of software.

 

Ubuntu:

 

Puppy:

 

They can be installed to USB with ...

 

Universal USB Installer:

 

Regarding your connection issue I've nothing to add to the already posted stuff, except a pretty simple fix I found for my sons laptop recently after I'd spent an age going through all his wi-fi settings ...

 

A function key on his laptop which toggled the laptops wi-fi on or off had been "toggled". Pressing the damned thing fixed it. I didn't even know laptops had this toggle key so didn't even think to look for it.

 

Regarding "Wireless Zero Configuration" (XP), yes, start the service and set it to automatic.

 

My router has it's own configuration utility, but it just doesn't handle this stuff anywhere near as good as Windows own service. In my experience.

Share this post


Link to post
Share on other sites

Mine actually has a dedicated row of those switches, as well as the "F" keys. Toggling the wireless switch was one of the first things I did, but no luck.

 

I've set the Wireless AutoConfig to automatic, but I'm not sure what I'm supposed to do after setting it to automatic. I rebooted, but still not connecting.

Share this post


Link to post
Share on other sites

... I bet they heard me "WHOOP" all the way to the 6th floor when it connected.

 

:lol:

 

For what its worth, Puppy linux runs entirely in ram off the CD and can be run that way off the usb stick also. So your HD isn't spinning needlessly. Tiny bit slower to boot, much faster operation if you have sufficient memory. One gb ram is easily enough, never tried less but many users say they get by with less.

 

Ubuntu is good too, a bit more full featured. Not sure how much it uses the HD. You can try'em both for little more than the cost of a CD / DVD.

Share this post


Link to post
Share on other sites

Well now I can't figure out how to install Flash Player on Ubuntu and I can't figure out how to even set up internet connections on Puppy. I really think this is some kind of sign from above that I shouldn't be watching youtube or Hulu at work <dave shakes his fist at the heavens>. :angry:

Share this post


Link to post
Share on other sites

I had Ubuntu installed on a thumb drive recently, but I would have to do it again to remember how I did everything, but there are plenty of guides on doing stuff with Ubuntu. Here's a couple on installing Flash ...

 

http://www.techiecorner.com/1659/how-to-install-flash-player-in-ubuntu/

 

http://www.psychocats.net/ubuntu/flash

 

You can google most problems, but of course post here if you're completely stuck and one of us will try sort you out.

 

Regarding Wireless AutoConfig, I always found Windows service better at searching for, and connecting to, local Wireless networks than my Belkin Wireless Utility.

 

Right clicking on the Wireless System Tray icon gives these options ...

 

 

 

With Windows Wireless Config service not running, you get this window in XP ...

 

 

 

With Wireless Config service running, you get this one ...

 

 

 

And as I mention above, I have always found Windows own config service better at seeking out, listing, and connecting to a local network.

 

Whether or not this will make a difference to your issue, I don't know, but if you haven't done this before, then you've got nothing to lose.

 

Credit of course to I think hazel above for raising this point.

Share this post


Link to post
Share on other sites

Well I guess the Wireless AutoConfig was started all along, although I'm positive it didn't say it was, because DennisD' bottom picture is what I've always gotten when I click on the signal strength bars down in the task bar. It shows all the available connections and tells me I'm connected but also says Limited Access.

 

Finally got Flash Player installed in Ubuntu. Was a matter of trial and error finding the right method online. The answer is probably obvious, but I'm booting from a USB now and every time I boot I have to install Flash again, and if Im at home I have to enter my router's key again. Is there no way to save this so I don't have to re-enter it each time, or is this because I'm running off a thumb drive?

Share this post


Link to post
Share on other sites

Sorry David, forgot to mention that to enable some Linux distro installations to retain all changes you make, including newly installed software, you have to make the installation "persistent".

 

Info and how-to here ...

 

http://www.howtogeek.com/howto/14912/create-a-persistent-bootable-ubuntu-usb-flash-drive/

 

If it's any consolation, some of us spent hours sussing this out by trial and error, but I haven't used Linux for some time. Gone rusty.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Well now I can't figure out how to install Flash Player on Ubuntu and I can't figure out how to even set up internet connections on Puppy. I really think this is some kind of sign from above that I shouldn't be watching youtube or Hulu at work <dave shakes his fist at the heavens>. :angry:

 

OK, have just hooked up with puppy (5.2.8) wireless. Here is what I had to know to accomplish it:

 

- the name of the wireless network. Puppy & this laptop (wxp home) discovered 4 of'em within range.

- the type of security the router was using (WPA, WEP, etc) and

- the security key.

 

Gonna sign off now and do it again in case I forgot something.

 

Btw, puppy is a gazillion times faster that windows on here. :)

 

Be right back.

Share this post


Link to post
Share on other sites

I was curious what that persistence thing was all about. Not curious enough to look it up apparently. ;)

 

Many thanks!!

Share this post


Link to post
Share on other sites

As soon as I booted the cd, puppy informed me that no network connection was available and offered the available options for this laptop. From there on it was only necessary to follow the screens and enter the required information.

 

I started the firewall in the default configuration, and chose firefox 5.01 for a browser.

 

Post back how it goes. :)

Share this post


Link to post
Share on other sites

Still no love from Puppy as far as internet goes. First it tells me my wireless adapter is a Realtek, but it's not. Then I click through a maze of setup boxes and it eventually recognizes that my adapter is an Intel. More setup boxes appear, most of which I have no idea what it's asking me, and no matter what combination I click when I scan for networks a box pops telling me something failed. Not that it sees connections and not that it doesn't see connections. Just that something failed. It's far too novice user unfriendly, and a giant pain to have to close Puppy so I can open WIndows so I can surf the web for information. With Ubuntu all I had to do was click the connections icon and enter the key for that network and I'm connected. I appreciate the help, but Ubuntu works fine for me. Puppy needs to be euthanized ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...