Jump to content
CCleaner Community Forums

3.04.1389 and AVG


moggy

Recommended Posts

Hello

 

I've been using CCleaner for years, but never had a reason to come here before - it's such a good, simple to understand program :D

 

However, I've just updated to 1389, and run an analysis, as always when I update, to find that it no longer lists any AVG files for deletion :( . As AVG is usually the biggest of the items CC cleans for me at shutdown, I hope it will remove what the previous versions did.

Link to post
Share on other sites

I've updated CCleaner three days ago for my home desktop (windows XP), Couple computers at work (one is XP the other is Vista) as well as my laptop (Windows 2000) and I noticed that even though AVG is checked CCleaner is not "seeing" the files on any of the Windows XP computers. Fine for the Vista and Windows 2000 though.

Link to post
Share on other sites

Agree totally. I've been googling this for days, no hits (go figure? are we the only two who have noticed?!) and finally came here. And I see you're not getting any joy here either.

Maybe we are the only two who have noticed!

We aren't the only ones - I had a ffreind (on XP Pro) check, and she got the same result. Notice this has been moved to the 'Bug report' subforum, so hopefully it means that it may be fixed in the next update.

Link to post
Share on other sites
  • Moderators

@All Please tell us what version of AVG you are using.

 

Currently these are the covered versions of avg and the areas looked for and cleaned

 

 

[Grisoft AVG 7.0]
ID=2128
LangSecRef=3024
Detect=HKLM\SOFTWARE\Grisoft\Avg7
Default=True
FileKey1=%commonappdata%\Grisoft\Avg7Data|*.log
FileKey2=%commonappdata%\Grisoft\Avg7Data\upd7bin|*.*
FileKey3=%commonappdata%\Grisoft\Avg7Data\$history|*.*
FileKey4=%commonappdata%\Grisoft\Avg7Data\avg7upd|*.log
FileKey5=%windir%\All Users\Application Data\Grisoft\Avg7Data\upd7bin|*.*
FileKey6=%windir%\All Users\Application Data\Grisoft\Avg7Data\avg7upd|$history
FileKey7=%windir%\All Users\Application Data\Grisoft\Avg7Data\avg7upd|*.log
FileKey8=%windir%\All Users\Application Data\Grisoft\Avg7Data|*.log
FileKey9=%windir%\Application Data\AVG7\Log|*.log

[AVG AntiVirus 8.0]
ID=2141
LangSecRef=3024
Detect=HKLM\SOFTWARE\AVG\Avg8
Default=True
FileKey1=%allusersprofile%\Application Data\avg8\Log|*.log
FileKey2=%allusersprofile%\Application Data\avg8\scanlogs|*.log
FileKey3=%allusersprofile%\Application Data\avg8\Log|*.xml
FileKey4=%allusersprofile%\Application Data\avg8\update\backup|*.*
FileKey5=%allusersprofile%\Application Data\avg8\Emc\Log|*.log

[AVG AntiVirus 9.0]
ID=2145
LangSecRef=3024
Detect=HKLM\SOFTWARE\AVG\Avg9
Default=True
FileKey1=%allusersprofile%\Application Data\avg9\Log|*.log
FileKey2=%allusersprofile%\Application Data\avg9\scanlogs|*.log
FileKey3=%allusersprofile%\Application Data\avg9\Log|*.xml
FileKey4=%allusersprofile%\Application Data\avg9\update\backup|*.*
FileKey5=%allusersprofile%\Application Data\avg9\Emc\Log|*.log

[AVG AntiVirus 10.0]
ID=2170
LangSecRef=3024
Detect=HKLM\SOFTWARE\AVG\Avg10
Default=True
FileKey1=%CommonAppData%\Application Data\avg10\Log|*.log
FileKey2=%CommonAppData%\Application Data\avg10\scanlogs|*.log
FileKey3=%CommonAppData%\Application Data\avg10\Log|*.xml
FileKey4=%CommonAppData%\Application Data\avg10\update\backup|*.*
FileKey5=%CommonAppData%\Application Data\avg10\Emc\Log|*.log
FileKey6=%CommonAppData%\Application Data\AVG10\IDS\config|*List.zip.bak
FileKey7=%CommonAppData%\Application Data\AVG10\IDS\profile|globalLoadable.bak
FileKey8=%CommonAppData%\Application Data\AVG10\Temp|*.tmp

If you need to know what any of that means, follow the Winapp2 link in my signature.

Link to post
Share on other sites

@All Please tell us what version of AVG you are using.

 

Program name: AVG Anti-virus

Program Version: 10.0.1204

 

Windows version: XP Home

EDIT

Found the flaw after writting a Winapp2.ini file and saving in the CCleaner folder.

 

[AVG AntiVirus 10.0] 
ID=2170 
LangSecRef=3024 
Detect=HKLM\SOFTWARE\AVG\Avg10 
Default=True 
FileKey1=%CommonAppData%\Application Data\avg10\Log|*.log 
FileKey2=%CommonAppData%\Application Data\avg10\scanlogs|*.log 
FileKey3=%CommonAppData%\Application Data\avg10\Log|*.xml 
FileKey4=%CommonAppData%\Application Data\avg10\update\backup|*.* 
FileKey5=%CommonAppData%\Application Data\avg10\Emc\Log|*.log 
FileKey6=%CommonAppData%\Application Data\AVG10\IDS\config|*List.zip.bak 
FileKey7=%CommonAppData%\Application Data\AVG10\IDS\profile|globalLoadable.bak 
FileKey8=%CommonAppData%\Application Data\AVG10\Temp|*.tmp

 

Didn't work but when I changed it to read

[*AVG AntiVirus 10.0*] 
ID=2170 
LangSecRef=3024 
Detect=HKLM\SOFTWARE\AVG\AVG10 
Default=True 
FileKey1=%allusersprofile%\Application Data\avg10\Log|*.log 
FileKey2=%allusersprofile%\Application Data\avg10\scanlogs|*.log 
FileKey3=%allusersprofile%\Application Data\avg10\Log|*.xml 
FileKey4=%allusersprofile%\Application Data\avg10\update\backup|*.* 
FileKey5=%allusersprofile%\Application Data\avg10\Emc\Log|*.log 
FileKey6=%allusersprofile%\Application Data\AVG10\IDS\config|*List.zip.bak 
FileKey7=%allusersprofile%\Application Data\AVG10\IDS\profile|globalLoadable.bak 
FileKey8=%allusersprofile%\Application Data\AVG10\Temp|*.tmp

it finally worked

Link to post
Share on other sites

AVG 10.0.1204

 

 

Thanks for the info Acey United :D , but I'm not comfortable with changing .ini files - hopefully CC will issue an update. meanwhile I'll stick to the older version.

Link to post
Share on other sites
  • Moderators

Wait so is the only change the capital lettersa in the detect key? If so I'll make sure the bug fixers see this. and it should go into the next version

 

Ah never mind the variable %commonappdata% and %allusersprofile% ok I will let the developers know

Link to post
Share on other sites
  • 3 weeks later...

Issue is persisting with 3.05.1408. Still no AVG 10.0 cleanup. :(

 

EDIT:

 

The AVG bug hasn't been fixed in 3.04.1408 -so I'm still using 1366.

Oops, I just noticed moggy reported this but he posted up "The AVG bug hasn't been fixed in 3.04.1408..." so that threw me a bit.

And I can't readily find a way to delete this posting.

Cheers.

Link to post
Share on other sites

For those of you who use XP and noticed CCleaner is NOT cleaning AVG 10, I made a zip file of winapp2.ini with only settings to clean AVG 10.

Just extract to C:\Program Files\CCleaner (assuming you didn't change where it installed to <_< )

 

EDITED BY MODERATOR: I'd rather not have Zip files from low post count members, sorry

Here are the contents (I've also taken the liberty to limit it to XP)

[XP AVG AntiVirus 10.0*]
LangSecRef=3024
Detect=HKLM\SOFTWARE\AVG\Avg10
DetectOS=|5.2
Default=True
FileKey1=%allusersprofile%\Application Data\avg10\Log|*.log
FileKey2=%allusersprofile%\Application Data\avg10\scanlogs|*.log
FileKey3=%allusersprofile%\Application Data\avg10\Log|*.xml
FileKey4=%allusersprofile%\Application Data\avg10\update\backup|*.*
FileKey5=%allusersprofile%\Application Data\avg10\Emc\Log|*.log
FileKey6=%allusersprofile%\Application Data\AVG10\IDS\config|*List.zip.bak
FileKey7=%allusersprofile%\Application Data\AVG10\IDS\profile|globalLoadable.bak
FileKey8=%allusersprofile%\Application Data\AVG10\Temp|*.tmp

Link to post
Share on other sites

Thanks for your effort. I can't speak for moggy but I'm not interested in a winapp2 workaround.

 

The point is: AVG cleaning worked just fine. Now it doesn't. Period.

 

That's not a deal breaker when considering it's freeware. I still choose to use CCleaner since it shines. If Piriform ever goes to a paid model, my PayPal account is at the ready. :)

 

Besides, AVG has its own resident cleanup tho not as thorough as was CCleaner's (Advanced Tools > Manage > Clean Up).

 

But really, it would be nice if that bug got fixed. Or if AVG cleanup can no longer be viable effected, then remove it from the selections.

 

Cheers!

Link to post
Share on other sites
  • Moderators
I can't speak for moggy but I'm not interested in a winapp2 workaround.

The Point of winapp2.ini is to bridge the time between now and when the devs fix it. There was no reason for you to answer in that manner

 

Most things added or fixed in ccleaner usually make a path through winapp2.ini (the file not the member ;) ) so...

 

make yer own bed :P

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...