Jump to content
CCleaner Community Forums

Speccy 1.08.218 crashes @ HD analysis


keynote

Recommended Posts

Running speccy for the first time on an older notebook: Compaq nx9010, XP/sp3

 

(note that Defraggler and Ccleaner have run fine on this machne before)

 

Speccy 1.08.218 fails with error message:

 

"Runtime Error!

Program: c:\program files\speccy\speccy.exe

This applicatin as requested the rutime to terminate in an unusual way..."

 

I ran in debug mode.

It only runs when the Hard Drive topbox is unchecked.

Hard drive is a ST94019A per device manager.

 

All other checkbox combinations work.

 

logfile with only HD checked:

 

[2011-01-30 01:42:31] [iNFO ] CPU SDK at: C:\DOCUME~1\User\LOCALS~1\Temp  speccycpuid.dll

 

logfile with all items checked:

 

[2011-01-30 01:44:27] [iNFO ] Monitor enumerator handle: 0x1A8030h
[2011-01-30 01:44:27] [iNFO ] Monitor HardwareId: Monitor\Default_Monitor 	 DriverId: {4D36E96E-E325-11CE-BFC1-08002BE10318}\0000
[2011-01-30 01:44:27] [iNFO ] Monitor HardwareId: Monitor\Default_Monitor 	 DriverId: {4D36E96E-E325-11CE-BFC1-08002BE10318}\0001
[2011-01-30 01:44:27] [iNFO ] Monitor HardwareId: Monitor\MS_0003 	 DriverId: {4D36E96E-E325-11CE-BFC1-08002BE10318}\0002
[2011-01-30 01:44:27] [iNFO ] Monitor driver name: RADEON IGP 345M
[2011-01-30 01:44:27] [iNFO ] Monitor mirroring driver: False
[2011-01-30 01:44:27] [iNFO ] Monitor display device active: False
[2011-01-30 01:44:27] [iNFO ] monitor device ID = < Monitor\Default_Monitor\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0001 >
[2011-01-30 01:44:27] [iNFO ] Monitor display device active: True
[2011-01-30 01:44:27] [iNFO ] monitor device ID = < Monitor\MS_0003\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0002 >
[2011-01-30 01:44:27] [iNFO ] Monitor display device active: False
[2011-01-30 01:44:27] [iNFO ] monitor device ID = < Monitor\Default_Monitor\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0000 >
[2011-01-30 01:44:27] [iNFO ] continue with monitor device ID = < Monitor\Default_Monitor\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0001 >
[2011-01-30 01:44:27] [iNFO ] monitorNameStr.IsEmpty()
[2011-01-30 01:44:27] [iNFO ] monitorNameStr = < Default Monitor >
[2011-01-30 01:44:27] [iNFO ] Monitor driver name: RADEON IGP 345M
[2011-01-30 01:44:27] [iNFO ] Monitor mirroring driver: False
[2011-01-30 01:44:27] [iNFO ] Monitor display device active: False
[2011-01-30 01:44:27] [iNFO ] monitor device ID = < Monitor\Default_Monitor\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0001 >
[2011-01-30 01:44:27] [iNFO ] Monitor display device active: False
[2011-01-30 01:44:27] [iNFO ] monitor device ID = < Monitor\MS_0003\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0002 >
[2011-01-30 01:44:27] [iNFO ] Monitor display device active: False
[2011-01-30 01:44:27] [iNFO ] monitor device ID = < Monitor\Default_Monitor\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0000 >
[2011-01-30 01:44:27] [iNFO ] continue with monitor device ID = < Monitor\Default_Monitor\{4D36E96E-E325-11CE-BFC1-08002BE10318}\0001 >
[2011-01-30 01:44:27] [iNFO ] monitorNameStr.IsEmpty()
[2011-01-30 01:44:27] [iNFO ] monitorNameStr = < Default Monitor >
[2011-01-30 01:44:27] [iNFO ] Monitor driver name: NetMeeting driver
[2011-01-30 01:44:27] [iNFO ] Monitor mirroring driver: True
[2011-01-30 01:44:27] [iNFO ] Monitor driver name: RDPDD Chained DD
[2011-01-30 01:44:27] [iNFO ] Monitor mirroring driver: True
[2011-01-30 01:44:27] [iNFO ] Driver: Try to load driver.
[2011-01-30 01:44:28] [iNFO ] CPU SDK at: C:\DOCUME~1\User\LOCALS~1\Temp  speccycpuid.dll
[2011-01-30 01:44:28] [iNFO ] Driver: Load driver OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012800 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012808 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x8001282C to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] ATI detection ATI Logging started
[2011-01-30 01:44:28] [iNFO ] ATI detection ATI Video: bus 1, dev 5, fnum 0
[2011-01-30 01:44:28] [iNFO ] Driver: Map memory addr C0000, 512 size.
[2011-01-30 01:44:28] [iNFO ] Driver: Mapping memory OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x0 to port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading memory addr 01AB0000, 4 size.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading memory OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x1 to port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Resizing memory to 61440 size.
[2011-01-30 01:44:28] [iNFO ] Driver: Unmapping memory.
[2011-01-30 01:44:28] [iNFO ] Driver: Unmapping memory OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Map memory addr C0000, 61440 size.
[2011-01-30 01:44:28] [iNFO ] Driver: Mapping memory OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Resizing memory OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x0 to port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading memory addr 01AB0000, 61440 size.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading memory OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x1 to port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012850 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Unmapping memory.
[2011-01-30 01:44:28] [iNFO ] Driver: Unmapping memory OK.
[2011-01-30 01:44:28] [iNFO ] ATI detection Try ATI SDK.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing 0x80012800 to port 0xCF8.
[2011-01-30 01:44:28] [iNFO ] Driver: Writing port OK.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading from port 0xCFC.
[2011-01-30 01:44:28] [iNFO ] Driver: Reading port OK.
[2011-01-30 01:44:28] [iNFO ] ATI detection Didn't find anything in registry
[2011-01-30 01:44:28] [iNFO ] Driver: Driver unload OK.

Link to post
Share on other sites
  • Moderators

The developers read all posts, so they'll have a look at this.

 

(I added code tags for easier reading)

Link to post
Share on other sites

I have been trying to use Speccy since v1.05, and always get the same Runtime error. It hangs up on the Hard Drives. I noticed that the problem was reported in http://forum.piriform.com/index.php?showtopic=29893&st=20, but it has never been fixed.

 

I am running Windows XP Home Edition Service Pack 3 (build 2600) with 1 Maxtor 6Y080P0 [Hard drive] (81.96 GB) -- drive 0, s/n ********, rev YAR41BW0, SMART Status: Healthy and 1 WDC WD200AA [Hard drive] (20.02 GB) -- drive 1, s/n ***************, rev 05.05B05, SMART Status: Healthy.

 

Log for Speccy in Debug mode without checking the Hard Drives option:Speccy_log1_08_2184-2-2011_16-15.txt

 

Log for Speccy after checking the Hard Drives option in Debug mode: Speccy_log1_08_2184-2-2011_16-22.txt

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...