Jump to content
CCleaner Community Forums
litedude

Winapp2.ini not loaded?

Recommended Posts

Hi,

 

I am using windows 7 64 bit. And i tried to add this piece of text to winapp2.ini:

 

[Google Earth]

LangSecRef=3021

Detect=HKCU\SOFTWARE\Google\Google Earth Pro

Default=True

FileKey1=%appdata%\Google\GoogleEarth|dbcache.dat

FileKey2=%appdata%\Google\GoogleEarth|dbcache.dat.index

RegKey1=HKCU\Software\Google\Google Earth Pro\Search

 

 

But it doesn't show up in Ccleaner. Not in the applications list nor in the results list which shows up after analysing.

 

 

The full path to winapp2.ini is C:\Program Files (x86)\CCleaner\Winapp2.ini.

 

Can someone help me to fix this?

 

 

Thanks ;)

 

Edit: oh, and because the manual says that the path must be \Program files\ and doesn't talk about \Program files (x86)\, I tried to put the file in C:\Program Files\CCleaner\Winapp2.ini (which I had to create). But that didn't work either.

Share this post


Link to post
Share on other sites

I think your problem may be that Google Earth is already a cleaner included in CCleaner by default if it isn't working I don't know why unless Google has changed something. This is what's in the old CCleaner version I use:

[Google Earth]
ID=2112
LangSecRef=3021
Detect=HKLM\SOFTWARE\Google\Google Earth Plus
Detect2=HKLM\SOFTWARE\Google\Google Earth Pro
Default=True
FileKey1=%appdata%\Google\GoogleEarth|dbcache.dat
FileKey2=%appdata%\Google\GoogleEarth|dbcache.dat.index
RegKey1=HKCU\Software\Google\Google Earth Plus\Search
RegKey2=HKCU\Software\Google\Google Earth Pro\Search

 

Perhaps changing the header name of the cleaner you made to this "may" allow it to show up and work (notice the asterisk before the name):

[*Google Earth]

Share this post


Link to post
Share on other sites
I think your problem may be that Google Earth is already a cleaner included in CCleaner by default if it isn't working I don't know why unless Google has changed something. This is what's in the old CCleaner version I use:

[Google Earth]
ID=2112
LangSecRef=3021
Detect=HKLM\SOFTWARE\Google\Google Earth Plus
Detect2=HKLM\SOFTWARE\Google\Google Earth Pro
Default=True
FileKey1=%appdata%\Google\GoogleEarth|dbcache.dat
FileKey2=%appdata%\Google\GoogleEarth|dbcache.dat.index
RegKey1=HKCU\Software\Google\Google Earth Plus\Search
RegKey2=HKCU\Software\Google\Google Earth Pro\Search

 

Perhaps changing the header name of the cleaner you made to this "may" allow it to show up and work (notice the asterisk before the name):

[*Google Earth]

 

I placed the code you provided in the winapp2.ini file (including the *), but still no google earth in ccleaner. :(

Share this post


Link to post
Share on other sites

How about changing it to a DetectFile=%program files%\(I don't know the google earth directory)|(I dont know the exe name).exe

Share this post


Link to post
Share on other sites

Why have 2 detect parameters? Also, is'nt there an HKCU reg entry to refernce? Otherwise both reg keys have to be present in order for CC to carry out the clean action. It wont act as an either or.

Share this post


Link to post
Share on other sites

Okay, I changed the detectfile to

DetectFile=%program files%\Google\Google Earth

 

At least i can see it in Ccleaner. But now, the problem is, that nothing is analysed.

 

The full path to the file i want to delete is:

C:\Users\***\AppData\LocalLow\Google\GoogleEarth\dbCache

 

 

I tried using these settings:

FileKey1=%LocalAppData%\Google\GoogleEarth|dbcache.dat

FileKey1=%appdata%\Google\GoogleEarth|dbcache.dat

 

 

But none of the worked. How do i get to \Appdata\LocalLow\Google?

Share this post


Link to post
Share on other sites
How do i get to \Appdata\LocalLow\Google?

Most likely you'll have to add that LocalLow path onto the cleaning routine otherwise it will always fail, try this using the code modified from what's already in CCleaner, don't know if it will work though - use Analyse first before committing to the clean!:

[*Google Earth]
ID=2112
LangSecRef=3021
Detect=HKLM\SOFTWARE\Google\Google Earth Plus
Detect2=HKLM\SOFTWARE\Google\Google Earth Pro
Default=True
FileKey1=%appdata%\LocalLow\Google\GoogleEarth|dbcache.dat
FileKey2=%appdata%\LocalLow\Google\GoogleEarth|dbcache.dat.index
RegKey1=HKCU\Software\Google\Google Earth Plus\Search
RegKey2=HKCU\Software\Google\Google Earth Pro\Search

 

If it still won't work with the above try this - use Analyze first before committing to the clean:

[*Google Earth]
ID=2112
LangSecRef=3021
Detect=HKLM\SOFTWARE\Google\Google Earth Plus
Detect2=HKLM\SOFTWARE\Google\Google Earth Pro
Default=True
FileKey1=%userprofile%\Application Data\LocalLow\Google\GoogleEarth|dbcache.dat
FileKey2=%userprofile%\Application Data\LocalLow\Google\GoogleEarth|dbcache.dat.index
RegKey1=HKCU\Software\Google\Google Earth Plus\Search
RegKey2=HKCU\Software\Google\Google Earth Pro\Search

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...