Jump to content
CCleaner Community Forums

"The parameter is incorrect"


davidpc

Recommended Posts

Hi, I have problems to retrieve pictures.

I have tried to retrieve teh found files by the program version 1.32.444 but I found a bug that it said : "The parameter is incorrect"

Then, I can?t move teh found pictures from the memory card to select folder to finish teh data retireval.

I would like know why this bug happen

What is the solution if is posible ???

Thanks

Link to post
Share on other sites
  • 3 weeks later...

I am having this same problem as well.

 

Recuva tells me that "The parameter is incorrect.", but it doesn't give me any detailed diagnostic information, or any other feedback at all for that matter.

 

I cannot find any explanation of the error in Piriform's documentation.

 

Would someone from Piriform, or someone else who has experienced this error, be able to document how I should proceed?

Link to post
Share on other sites
  • 2 weeks later...

I, too, am getting the message "The parameter is incorrect."

 

The drive is set to "Removable Disk (D:)", a 4 GB USB drive that I accidentally messed up when reinstalling Windows XP. (I thought it was a partition on my hard drive and deleted it :( ) Another recovery program found files on this drive (but recovered them to my hard disk), so the drive isn't hopeless. (I was hoping Recuva would do a better job by showing file names and the folder structure.)

 

The File or Path dropdown is left blank, to scan for all files.

 

The General Options are English, Tree View, automatically check for updates, simple overwrite.

 

The Actions are Show files found in hidden system directories, Scan for non-deleted files, and Restore folder structure.

 

When I click on the Scan button, the message "The parameter is incorrect." appears immediately under the big (empty) results listing box, on the left.

 

Here's the debug file:

 

[2010-01-05 21:04:01] [iNFO ] Recuva v1.34.460

[2010-01-05 21:04:01] [iNFO ] System Info: MS Windows XP Home SP3, Intel Pentium 4 CPU 1.70GHz, 1.0GB RAM, NVIDIA GeForce2 MX

[2010-01-05 21:04:02] [iNFO ] No update available

[2010-01-05 21:04:27] [ERROR] Read error 57 (C000000D) at 0 trying to read 512 bytes

[2010-01-05 21:04:27] [ERROR] Read error 57 (C000000D) at 0 trying to read 512 bytes

[2010-01-05 21:04:28] [iNFO ] Exception information saved at Recuva.exe_6-1-2010_02-04-27-546.dmp

[2010-01-05 21:04:28] [ERROR] COM exception: DriveInfoImpl.cpp(288) : The parameter is incorrect. (0x80070057)

Link to post
Share on other sites
  • 6 months later...

I am having exactly the same issue with exactly the same results. Accidentally deleted the partition on a 4GB USB drive while reinstalling WInXP. Did NOT format. Running recuva on a Win7 machine to try and get the USB drive back. I get exactly the same problem. I have a crashdump. Anyone have any luck on this?

 

I got "Error, you arent permitted to upload this kind of file" when I tried to attach the crashdump.

 

Help!

 

Thanks in advance!

Link to post
Share on other sites
  • Moderators

This may be of some help in "undeleting" a deleted partition:

 

Rescue Kit 10 Free Edition:

 

Undelete Partition

 

When simply deleting a partition (without additional wiping) disk management software only removes the references to it in the Partition Table, thus leaving the possibility to recover it later. The Undelete Partitions Wizard enables you to find and recover these partitions. A restored partition will be fully functional, as long as other partitions were not created, moved or exceeded the disk space.

 

Although I have this stored on CD, I've never had cause to use it, so I can't vouch for it's effectiveness, but it's worth a shot.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...