Jump to content
CCleaner Community Forums

GUI breaks after long defrag

Recommended Posts

Hello Piriform Community, new member here


Sorry if this has already been discussed. When I do a regular Defrag, after a looooong time (5+ hours?) I'll come back to find this:






Defraggler version 1.12.152

15.4" Compal JHL90 Laptop

Windows XP Pro SP3

Intel Core2 Duo T9400


200 GB 7200rpm 16 MB cache HDD

NVIDIA GeForce 9600M GT, driver version 179.48

1680x1050 screen resolution



Apparently the defrag process is still going as the harddrive is busy working away and the green & yellow blocks are moving files about the map.


At this point, when the mouse is moved around the screen, text such as 'Analyze', 'Defrag', 'Pause', and 'Stop' appear the moment the mouse passes the button, however the buttons themselves do not change on mouseover.


Additionally, when you select a menu, the menu drops down and it completely solid black. And when you drag the cursor down the menu, the menu items appear.


I just downloaded updated GeForce drivers (185.85) and will install that today. I have another external HDD I need to defrag tonight, so I will report back if the display drivers fixed the problem.


Thanks for looking into this, and sorry if it has already been addressed!

Link to post
Share on other sites

Ok guys, I have some updates.


This appears to be a memory leak? Please consider the screen shots from last night's night-long defrag of my 1 TB external HDD.


The moment I hit 'Print Screen', I got a 'Insufficient memory to create the bitmap. Close' popup window. So I had to use my ol' trusty Paint Shop Pro to take some additional screen captures.


Here is the first one. I Alt-Tab'd back to Defraggler and the Alt-Tab screen stayed on top of Defraggler. Also, some of the paint shop pro tools remained atop Defraggler despite having switched to the Defraggler application, as you can see in the Task Bar at the bottom.




Here is a screen capture of only the popup prompt:




I then clicked OK ok the 'Insufficient memory' popup and most of Defraggler cleared up, but you can see below, the paint shop pro graphics tools are still there. So I clicked on the File menu to get the SOLID BLACK menu to drop down, and took the following screen shot. Again, I have already let go of the Alt key after Alt-Tabing over to Defraggler, yet the Alt-Tab window remained atop Defraggler (burned in).




And finally, I wanted to show the memory usage from Defraggler. I have 2 GB on this machine, so only about 50% of my physical memory was used.




Yeah.......... 437 MB of memory used by Defraggler. WOW


So this is after doing the nVidia GeForce update to 185.85, which according to the website, is the most recent update.


Am I correct in assuming I am the first to report this?


Thank you very much,


Link to post
Share on other sites

Hey guys,


After re-reading this thread, I need to point out that both of these issues have come from my external USB 1-TB HDD. But in my opening post, I mentioned my 200 GB internal laptop HDD, which these screen shots are not from, HOWEVER, I have indeed had this problem even while defragmenting my internal 200 GB HDD.


So both cases apply.

Link to post
Share on other sites

I see the same bug with my laptops 160Gb IDE...


I'm hoping its just a rendering bug!!


In this state I see the following;

There the staircase white blocks on the drive content panel; changes as you mouse over it.

The drives panel content doesn't update correctly; black in undrawn areas.

The Drive properties panel content was drawn at global 0,0.

The progress dialog has most of its frame but no content.



Feature request for the version that fixes this; A way to spec directories to move tot he back of the drive.


Link to post
Share on other sites

Wow! That is worse than mine!!


Last night I was going to defrag my internal drive (to produce the same error) but I need to transfer a bunch of files to my backup drive, so I'll defrag after I do that and will report back.




Link to post
Share on other sites
  • Moderators

One of the devs replies in post 3 of this thread.


Are you saying it exsisted in version 1.12 for you, and is still not fixed in 1.13?

CCleaner documentation can be found here


Support contact




Link to post
Share on other sites
  • Moderators
This looks like a graphics issue and should be fixed in the next release.

I can confirm that NVIDIA drivers in a few previous versions caused display corruption in some applications CDBurnerXP is another for example, never once noticed it in Defraggler though.


Updating the NVIDIA drivers to the newest version may fix the issue, if this isn't actually a Defraggler issue:



If it isn't a Defraggler issue the display corruption should be reported to NVIDIA with screenshots:


Link to post
Share on other sites
One of the devs replies in post 3 of this thread.



The developer replied to a "graphical" problem when in fact this is a memory overrun problem, if not both.



Updating the NVIDIA drivers to the newest version may fix the issue


Please read this thread before replying. I have already upgraded to the latest NVIDIA drivers.



Honestly, I am just wondering what the developers think of the near 500 MB memory requirement for Defraggler, which I don't believe is normal since it crashed a feature of my operating system (print screen functionality).



Link to post
Share on other sites
  • 2 weeks later...

Been about two weeks now.


This problem is still causing my Defraggler to slow my system to a halt... so what I have been doing is limiting my defrags to about 2 hours, but it is very annoying setting alarms and having to come back to shut down the application.


Really I only defrag about once every two weeks or so, but I was just wondering if this bug has been fixed yet is all....



Thank you very much in advance,


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...