Jump to content

Defraggler extremely slow


Recommended Posts

It would help the developers if you could run Defraggler in "Debug" mode and post the log here.

There are many entries like this in my log:

[2010-03-10] [15:18:20.906] 00bac 1 CVolume::UpdateDriveMap#340 Map generated in 1.59413 seconds.
[2010-03-10] [15:18:23.000] 00bac 1 CVolume::UpdateDriveMap#340 Map generated in 1.59111 seconds.
[2010-03-10] [15:18:25.078] 00bac 1 CVolume::UpdateDriveMap#340 Map generated in 1.57261 seconds.
[2010-03-10] [15:18:27.156] 00bac 1 CVolume::UpdateDriveMap#340 Map generated in 1.58249 seconds.

Defraggler is very slow for me. It's utilizes CPU resources very much.

Log attached.


Link to comment
Share on other sites

Summary: the problem of a seemingly halted defragmentation process may be solved by turning off the option 'Move large files to end of drive...', regardless of the System Restore settings.


Hello, I too experience a very slow defragmentation process. Fortunately, thanks to the remarks of Danno, I was able to solve my problem by turning off the option to move large files to the end of the drive.


I also turned off "Move large files to end of drive... (all sizes & other set to default)" and increased speed dramatically.


My system:

windows7 64bit

6gb ram

i7 920 @ 3.0


hdd that was used is WD VelociRaptor 150GB 10000RPM SATA-II 16MB Cache

Used space: 117GB

Free space: 22GB

No operating system installed on it, hdd just being used for games


Defraggler version v1.17.172 (64 bit)

Link to comment
Share on other sites

One more confirmation. Using the latest version runs slow if you have "Move large files to end" option checked. I unchecked it and it is running much as I expected.





Well, it really has been confirmed already, don't you think ;).

Link to comment
Share on other sites

Hi there,

i have the same problem defraggler hungs up in a "loop" one time the loop starts at 71%, then i stopped defragmentation. Sart again, it hungs up on 63%.

Windows Vista

2,1 Ghz dual core

I am very sad, want to use defraggler, because for me it did in the past a realy good job.

Until yesterday i used the newest version of defraggler.

For me it seems like some Problems with restore points like some users wrote allready, because a couple of days ago i had trouble with my videocard i reinstalled it on my notebook and in the loop it always shows the same after a while. C.../ATI...

I hope you can fix the bug!

Link to comment
Share on other sites

It doesn't clearly come up, what exactly is your problem. The volume shadow copy thingy is morely a windows bug. It sences the file moves and "backups" the files which quickly fills up the HDD until they are purged. You can read about it here: http://docs.piriform.com/defraggler/techni...e-shadow-copies


Also did you try "Fast Defrag" and/or deselecting the "Move Large files at the end of the drive" (or whatever it was named as).

Link to comment
Share on other sites

hello guys,


I'm using defraggler too. And I have to say, that the needed time to defrag my c partition is realy bad.


For example at 69 percent he needs 4 hours to get to 70 .....

That's really hard. And on top he caused 100 percent processor load over the hole defragprocess.

For example I, for a full system recovery I need about 1 hour. And the result is the same.


Sry for my worse englisch....


best regards



Link to comment
Share on other sites

  • 2 weeks later...

Hi there,


Sorry for such a negative first post but I think I am encountering the issues mentioned in this thread.


I have defraggler deployed on 450 workstations (XP SP2) on our network set to run a daily quick defrag. Yesterday I noticed one of the computers was going very slow, upon investigation I saw df.exe using 100% of the CPU and not appearing to do anything.


When I then launched the GUI program and run a quick defrag, the same thing happens, the program builds the file list correctly, then once it starts defragging, CPU usage jumps to 100% in task manager and it is defragging only about 1 file every couple of seconds.


I have tested with the newest defraggler version (1.18.185) and unfortunately the problem is still there.


So far it is occuring on 2 out of the 7 computers I have tried. System restore is disabled on them all.


Running a defrag in windows bult-in disk defragmenter works fine on them, they are new machines (2 years or newer) so I don't suspect any hardware failure.


Aside from that negativity I am very pleased with the program and since rolling out across the network we have recieved no complaints at all, keep up the good work!

Link to comment
Share on other sites

S-L-O-W latest version of defraggler!

I was using the older version 1.17 and when I began to use Defraggler, I was offered the newest 1.18 version...so I downloaded it from File Hippo. BUT...when I began defraggling, it took 15 minutes to defrag 2% (longer than it took to ever defrag my entire system in the past).


I thought perhaps I received a bad download, so I uninstalled it...went to File Hippo and downloaded a 2nd file...opened it and ran it. OOPS...it still took about 15 to get 2% defragged!


Well, I was sure there must be some sort of bug in the newest version because I had never seen that ever happen "to me" before. SO...I uninstalled it, again, and downloaded the 1.17 version, again...and "voila", the older one still worked like a charm.


I guess I'll keep the older version until a newer version comes out because nobody can be expected to wait for a defrag at the rate of 2% every 15 minutes, right?


QUESTION: Am I only one of a few people experiencing this extreme slowness with the latest version?

Link to comment
Share on other sites

So I have been running Defraggler for a couple of years now. It usually takes a couple of days to finish, but apparently its not suppose to?

I have to set of time out of the year, once or twice to run it.

I am running it right now, first time this year. It will take about 60 hours for it to finish, 12% right now.


Would it help if I ran the debug version and send you the log file? Seeing as I am also one of the people that is having trouble with the software being slow.

I run it in Safe mode under WinXP and always have. Does it really matter?

Anyway, just wanted to let you know. Its always been like this for me, for years. So I just expected it to be that way, thats the way the Windows one was on my older PC's (Win 98 era).

Link to comment
Share on other sites

  • 5 weeks later...

1.19.* will be released in a matter of days. We'll just have to see whether the devs have the time or interest to fix this and the other issues mentioned in this topic (that btw. should have been put into a new topic).

Link to comment
Share on other sites

I too am having similar problems. I just d/led the very newest version and it doesn't seem to have affect this bug at all.


I am defragging a highly fragmented (~70%) 500Gb external drive that I use for video storage and backups. I have several very large files (a few 2-4gb and 2-3 20+gb) on this drive. Drefraggler seems to be working, but if you watch it, it moves a fragment to one block, then back, then to another, than back and repeats. It seems to pick 2-3 blocks and just rotates the same couple fragments around in them, and never gets anything done.


It's very frustrating.

Link to comment
Share on other sites

update: running the "Check Drive for Errors" tool within Defraggler. It immediately detected many corrupt attribute records and orphan file records. Could this have something to do with the previously reported problems with Defraggler messing with the MFT??

Link to comment
Share on other sites

At least twice as annoyed and extremely angry in addition, now.


After running the Verify Disk utility, Defraggler has deleted several .rar archive files from my drive as well as an incremental backup file.


Several of these were rather important and are now completely unrecoverable.


They still appear on the drive, but show as 0 bytes. Any attempt to access them says they are "unknown format or damaged".

Link to comment
Share on other sites

Tried downloading Recuva to restore the files, but it says it cannot restore a file of size 0 bytes. All my .rar archives are pretty much destroyed, along with content and backups that do not exist elsewhere - as this was a backup drive.


I have used Defraggler for a long time and never had any problems with it...but this sort of failure is completely unacceptable! What is going on with this software???

Link to comment
Share on other sites

Defraggler is slow for me also, specially on big partitions using the DEFRAG (not the quick one) option. I think it's spending most of its time filling gaps for some reason and it's taking it a lot more time than any other defragger. Maybe it's laying out files using some sorting order. I don't know.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.