Jump to content
CCleaner Community Forums
Newhotness

Searching from the My Computer Screen

Recommended Posts

I've just recently discovered a rather annoying thing happening in My Computer folder. When you go to click on the drives, c: d: e: etc. or My Documents, its brings up a search window searching that location rather than the actual folder. Not as if it can't find the folder, but rather that its trying to do a Windows search of the folder. Hopefully someone here knows of this and can help me set it back to the defaults. Thankx

Share this post


Link to post
Share on other sites

Make a System Restore point before using the .reg file!

 

Note: Name the file directory.reg. A note to everyone else, the file is only for Newhotness.

 

 

Windows Registry Editor Version 5.00[HKEY_CLASSES_ROOT\Directory]@="File Folder""AlwaysShowExt"="""EditFlags"=dword:000001d2"InfoTip"="prop:DocComments"[HKEY_CLASSES_ROOT\Directory\Background][HKEY_CLASSES_ROOT\Directory\Background\shellex][HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers][HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New]@="{D969A300-E7FF-11d0-A93B-00A0C90F2719}"[HKEY_CLASSES_ROOT\Directory\DefaultIcon]@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\?00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\?65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,00,00[HKEY_CLASSES_ROOT\Directory\shell]@="none"[HKEY_CLASSES_ROOT\Directory\shell\find]"SuppressionPolicy"=dword:00000080[HKEY_CLASSES_ROOT\Directory\shell\find\command]@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\?00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\?65,00,00,00[HKEY_CLASSES_ROOT\Directory\shell\find\ddeexec]@="[FindFolder(\"%l\", %I)]""NoActivateHandler"=""[HKEY_CLASSES_ROOT\Directory\shell\find\ddeexec\application]@="Folders"[HKEY_CLASSES_ROOT\Directory\shell\find\ddeexec\topic]@="AppProperties"[HKEY_CLASSES_ROOT\Directory\shellex][HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers][HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\EncryptionMenu]@="{A470F8CF-A1E8-4f65-8335-227475AA5C46}"[HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\Offline Files]@="{750fdf0e-2a26-11d1-a3ea-080036587f03}"[HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\Sharing]@="{f81e9010-6ea4-11ce-a7ff-00aa003ca9f6}"[HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers][HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers\CDF]@="{67EA19A0-CCEF-11d0-8024-00C04FD75D13}"[HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers\FileSystem]@="{217FC9C0-3AEA-1069-A2DB-08002B30309D}"[HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers\MyDocuments]@="{ECF03A33-103D-11d2-854D-006008059367}"[HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers\Sharing]@="{40dd6e20-7c17-11ce-a804-00aa003ca9f6}"[HKEY_CLASSES_ROOT\Directory\shellex\DragDropHandlers][HKEY_CLASSES_ROOT\Directory\shellex\PropertySheetHandlers][HKEY_CLASSES_ROOT\Directory\shellex\PropertySheetHandlers\Sharing]@="{f81e9010-6ea4-11ce-a7ff-00aa003ca9f6}"[HKEY_CLASSES_ROOT\Directory\shellex\PropertySheetHandlers\{1F2E5C40-9550-11CE-99D2-00AA006E086C}][HKEY_CLASSES_ROOT\Directory\shellex\PropertySheetHandlers\{596AB062-B4D2-4215-9F74-E9109B0A8153}]@=""[HKEY_CLASSES_ROOT\Directory\shellex\PropertySheetHandlers\{ECCDF543-45CC-11CE-B9BF-0080C87CDBA6}][HKEY_CLASSES_ROOT\Directory\shellex\PropertySheetHandlers\{ef43ecfe-2ab9-4632-bf21-58909dd177f0}]@=""

 

Edit: If this doesn't fix it, there's another possibility.

Share this post


Link to post
Share on other sites

Andavari,

 

thankx for the code...what exactly do i do with it once i save it. This is the first time i've had to use a file like this.

Share this post


Link to post
Share on other sites

1. Copy the code and paste it into an empty Notepad window, and save it as a registry entry file on the desktop or wherever, such as for example (use the quotes): "directory.reg"

2. Make a System Restore point! I don't know if it will fix the problem or not.

3. Double click the registry entry file: directory.reg

4. I recommend that you either log off, or restart Windows and then see if it fixed the problem. If it didn't fix the problem you can use the System Restore point to put things back the way they were and we can continue to try and figure out a solution.

Share this post


Link to post
Share on other sites
Wait, you are using Windows XP aren't you?

 

 

 

 

ya i am using XP, thankx for all the registry help, one more question though, with .reg files, once you click them do you have to keep them or are they like a one time use file?

Share this post


Link to post
Share on other sites
ya i am using XP, thankx for all the registry help, one more question though, with .reg files, once you click them do you have to keep them or are they like a one time use file?

 

 

 

Good you're on XP, I was thinking I screwed up by giving you that .reg file without first knowing what OS you were using, whew.

 

The .reg file you can keep or delete it's up to you. It can be re-used again if the same problem resurfaces. I personally have a collection of .reg files to fix some common problems I've experienced over the years.

Share this post


Link to post
Share on other sites
Good you're on XP, I was thinking I screwed up by giving you that .reg file without first knowing what OS you were using, whew.

 

The .reg file you can keep or delete it's up to you. It can be re-used again if the same problem resurfaces. I personally have a collection of .reg files to fix some common problems I've experienced over the years.

 

 

 

 

I've been away from my computer for a few days now so i havn't had a chance to try it out yet, but i noticed last night on it when i right click normal documents/folders/etc that the first option is OPEN, but with these drives the first option is SEARCH, then OPEN is 2nd, is this why its defaulting to the search option and if so, is that what this .reg file is designed to fix? sorry for all the q's, but everything you've said so far makes sense so i figured whats the harm in prodding you for a little more knowledge. thankx

Share this post


Link to post
Share on other sites

The default option for folders and drives listed in My Computer is Open.

 

It's one of the easiest things to mess up when playing around with "Tools->Folder Options->File Types" which is really silly after all these years. It's hard to believe that Microsoft still allows the default option to be so easily changed, it should really be a setting that's hard-coded and can't be changed. I went through the same problem many years ago messing with the Folder and Drive settings in File Types.

 

I've seen programs in that past mess them up, of course that's when a program put's itself either in the folder or drives right click menu and screws them up during uninstall. Also I've seen some "tweak" programs mess up the default settings.

Share this post


Link to post
Share on other sites
Umm... Take you a long time to find the answer?

 

23738[/snapback]

 

 

 

Lol. My .reg file would've fixed it then.

Share this post


Link to post
Share on other sites

I just had it happen to me, and it was happening on other forums too. There was even a link to this thread. So I posted the solution in case others come here from other forums.

Share this post


Link to post
Share on other sites
I just had it happen to me, and it was happening on other forums too.

 

23797[/snapback]

 

 

 

Looks like it's a common problem then. At least it can be fixed in a matter of seconds.

Share this post


Link to post
Share on other sites

I had the same problem , I did a restore and it corrected...Don't know why or how it happened...

Share this post


Link to post
Share on other sites

It happens when you edit the File Folder or something of the likes under Folder Options > File Types. Clicking Advanced triggers it to clear out that registry key (which usually will read "none") and thus causes the error.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...