Jump to content
CCleaner Community Forums

BUG - Scheduled Defrag


MCT1986

Recommended Posts

hey, im a first time user of Defraggler, but not new to your other products

anyways, I try to set a scheduled defrag & it will not let me

 

"Problem - Defraggler was unable to change the options"

 

I dunno why this is, im an advanced windows user

Link to post
Share on other sites
hey, im a first time user of Defraggler, but not new to your other products

anyways, I try to set a scheduled defrag & it will not let me

 

"Problem - Defraggler was unable to change the options"

 

I dunno why this is, im an advanced windows user

Yes, I noticed the message when trying to use the scheduler. I made a comment earlier about it under the comment thread, but no one has yet to respond.

Link to post
Share on other sites

I've found that settings for the scheduler will only be accepted for drives(partitions) that are not highlighted on the Defraggler screen, which if you only have 1 drive, with no floppy or USB drive, could be a real problem. You can set up non-highlighted drives and then move the highlight to a different drive to set up the first drive. That seemed to work OK for my system. Then you can go into Windows Scheduled Tasks to tweak the settings if you want. Hope this may help some folks get it working.

Link to post
Share on other sites
I've found that settings for the scheduler will only be accepted for drives(partitions) that are not highlighted on the Defraggler screen, which if you only have 1 drive, with no floppy or USB drive, could be a real problem. You can set up non-highlighted drives and then move the highlight to a different drive to set up the first drive. That seemed to work OK for my system. Then you can go into Windows Scheduled Tasks to tweak the settings if you want. Hope this may help some folks get it working.

I found that it would not set up a scheduled defrag no matter what I did, highlighted drive or not. I am running Vista if that is relevant.

Link to post
Share on other sites

Can you post some more details about this issue. Please include:

 

- OS

- User account type

- Does the schedule appear Windows Task Scheduler

- Can you create a task manually in Windows Task Scheduler

 

Thanks

MrRon

Link to post
Share on other sites
I found that it would not set up a scheduled defrag no matter what I did, highlighted drive or not. I am running Vista if that is relevant.

 

My experience was with XP with SP3. Don't know about Vista. Are you set up as an Administrator account? That would be my first Guess! I might check that out this afternoon on my daughter's laptop. It has Vista Home Premium on it. If I find something, I'll post back.

Link to post
Share on other sites
My experience was with XP with SP3. Don't know about Vista. Are you set up as an Administrator account? That would be my first Guess! I might check that out this afternoon on my daughter's laptop. It has Vista Home Premium on it. If I find something, I'll post back.

 

It worked in XP but I had to wrangle it a bit. If you first select a different drive in the drives list (preferably A:) and then first create a "Now" schedule for the drive you want, and then click ok to create the schedule. After that you can go back in and change it to a daily, weekly, or monthly schedule. Check the windows xp control panel to see what schedules have been created. I also noticed that when df.exe runs scheduled it doesn't have a window... i.e. it's running as a hidden task. This can be a pain if you want to end the defrag session. Oh well.. it's free and it seems to do a great job. Microsoft should have done this years ago those silly turds

Link to post
Share on other sites

I can setup and tweak the tasks OK in XP. I can't seem to get it tweaked to my liking in Vista tho. My next concern is, as you mentioned, that the scheduled task runs blind. I didn't see a pop-up reminder that it was starting., nor any means to stop it once it's started. I hope that there is a good overlap in the read/write/erase process to prevent data loss in the case of an inadvertent shutdown, or if one would terminate the process! I don't have a system running, that I'm willing to test this on yet. Anyone have experience with this?

Link to post
Share on other sites

I've just tried out the latest version - 1.3.094 - and can confirm that this problem is still occuring. I am running XP pro Spanish, fully patched. I have tried this using a domain admin account - i.e full privs and still no go.

 

I've tried the select different drive solution mentioned above but it does nothing on my machine.

 

A better help message you be a good idea here - what is it that its trying to do? It should say what it failed to do and what error was returned and by what.

 

Excellent tool btw

 

Ian

Link to post
Share on other sites

Just noticed that there is a debug mode. This is the log showing what fails when I try to schedule a defrag.

 

[2008-10-20] [12:44:08.813] 00b48 1 CVolumeManagerBase::GetBasicVolumeInfo#217 Unsupported drive type 5 for volume Z:
[2008-10-20] [12:44:08.813] 00b48 1 CVolumeManagerBase::UpdateVolume#298 Finish update for bvi Z:.
[2008-10-20] [12:44:21.891] 01188 1 CVolumeNavigator::SelectVolume#271 New volume selected: A:.
[2008-10-20] [12:44:21.891] 01188 1 CFilesListViewImpl::DoSort#263 Sorting 0 elements took 0.0000 seconds
[2008-10-20] [12:44:21.891] 01188 1 FindResourceNameFromOrdinal::FindResourceIdFromOrdinal::BeginSearching#73 EnumResourceNames failed (hr=0x00000000)
[2008-10-20] [12:44:24.015] 01188 1 CFilesListViewImpl::DoSort#263 Sorting 0 elements took 0.0000 seconds
[2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#150 VolumesMap size = 5
[2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task
[2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task
[2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task
[2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task
[2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task
[2008-10-20] [12:44:25.219] 01188 1 CTaskSchedule::LoadTasks#281 Error occured while getting task data from Task Scheduler. HRESULT: -2147216631
[2008-10-20] [12:44:35.484] 01188 1 CTaskSchedule::SaveTasks#239 AddTask Error. HRESULT: -2147024809
[2008-10-20] [12:44:38.562] 01188 1 CMainFrame::OnDestroy#439 Entering CMainFrame::OnDestroy
[2008-10-20] [12:44:38.562] 01188 1 CVolumeNavigator::Shutdown#74 Entering CVolumeNavigator::Shutdown
[2008-10-20] [12:44:38.562] 01188 1 CVolumeNavigator::Shutdown#74 Leaving CVolumeNavigator::Shutdown
[2008-10-20] [12:44:38.562] 01188 1 CVolumeManager::Shutdown#35 Entering CVolumeManager::Shutdown
[2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x00000574
[2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x00000470
[2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x0000048c
[2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x000006a4
[2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::Shutdown#35 Leaving CVolumeManager::Shutdown
[2008-10-20] [12:44:38.671] 01188 1 CMainFrame::OnDestroy#439 Leaving CMainFrame::OnDestroy
[2008-10-20] [12:44:38.671] 01188 1 CMainFrame::~CMainFrame#131 Entering CMainFrame::~CMainFrame
[2008-10-20] [12:44:38.671] 01188 1 CMainFrame::~CMainFrame#131 Leaving CMainFrame::~CMainFrame

 

 

The pertinient line seems to be

CTaskSchedule::LoadTasks#281 Error occured while getting task data from Task Scheduler. HRESULT: -2147216631

 

I googled this but didn't find anything of use.

 

However in task scheduler I found a task half programed. In the Task properties the Execute or Run field (not sure - my pc is in spanish), contains

 

c:\df.exe c:

 

and the schedule is blank.

 

Defraggler is installed into C:\Archivos de Programa\Defraggler - the equiv of program files under spanish XP.

 

Hope this is of some use in debugging the problem.

 

Ian

Link to post
Share on other sites
  • 10 months later...
  • 9 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...