Jump to content
CCleaner Community Forums

How does Defraggler handle partitions mounted at folder locations?


Recommended Posts

Let me explain my setup:

 

I have three HDDs but only the first one is really relevant. I partitioned the first HDD into three partitions, two large partitions with a small partition in between (all primary partitions). The first partition is mounted at C: and has the OS installed. (Windows XP) The second partition is 2x the amount of RAM I have and all (except 5MB) is a designated pagefile. (This guarantees a contiguous swapspace. Normally I would put it at the front of the drive but that can somehow cause boot problems with some versions of windows.) The third partition is mounted at C:\Programs\

 

When I install Programs I change the default install path from C:\Program Files\XXXX\ to C:\Programs\XXXX\

 

This ensures that:

1. my program files do not get intermingled on disk with my system files,

2. most anything installed without my consent (goes into C:\Program Files\ by default) is readily browse-able.

3. my program files are contiguous and programs installed by me are easily identifiable

 

Anyway I like how it keeps things neat. However, when I run defraggler the 'Programs' mount does not appear as an option. If I defrag C:\ and then try to defrag C:\Programs using the Defrag Folder option, it appears to already be defragged.

 

 

My question is, how does defraggler currently handle this and can I force a defrag on only one area at a time? (or would you implement a by-partition defrag) since defragging both areas at the same time slows down the drive. (Also I wouldn't want files moved from one partition to the other...)

 

On a GUI note, more detail is shown when the viewing pane is expanded by dragging it down. How about adding a checkbox "Drive View in Maximum Resolution" where a scrollbar is added and the viewing pane is made tall enough to display the drive in full detail?

Link to post
Share on other sites
  • 2 months later...

I have the same problem. I have 5 drives mounted to 5 empty directories on my D drive. Defraggler does not see any of these. It simply sees 5 empty folders on the D drive which are by definition free of fragmentation. Your C:\Programs is simply an empty directory or folder and your mounted drive does not exist. If you have free drive letters (I don't as I use them as virtual drives loaded with virtual CDs) you can leave it mounted at C:\Programs whilst simultaneously allowing it a drive letter (H say) and Defraggler will see it as the H drive and defragment it as a separate drive. This will fix you until Defraggler is fixed.

 

Microsoft in its description of mounted drives gives an example where a CD/DVD drive is mounted. Unfortunately if you do this I found that Autorun won't work and there are other problems with CD/DVD recognition so I went back to drive letters.

Link to post
Share on other sites
  • 4 years later...

Uff! First, I thought the problem, that Defraggler cannot handle as a folder mounted partitions, was never reported before. Now I see that this problem is known since 2008 (!!!). Until right now I cannot see that Defraggler has a solution for this OS feature. I have, like the two members before, hard drives, which were mounted in a empty folder. In Defraggler I can see the drive with the folder inside in which these drives are mounted but I cannot defrag this drives because Defraggler doesn't recognize the folders and files on the mounted hard drives. So the question is: How can I defrag drives mounted like this with Defraggler. By the way: O&O's defrag software CAN defrag such drives and shows them correctly for example like D:\MyFiles\MountedFolder\DriveOne !!!

Link to post
Share on other sites
  • Moderators

Shabba, please stop posting in ancient topics. It's pointless responding to topics relating to four-year-old releases. If you have anything to say open a new topic. I have removed your two other posts which really added nothing.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...