Jump to content

Flashdrive problems (chkdsk) - Samsung "MightyDrive" 4GB


Recommended Posts

I have problem with a flashdrive: Samsung "MightyDrive" 4GB. Using chkdsk /f produced the following errors:

"Removing trailing folder entries from ..."

"Removing nonvalid long folder entry from ... "

"... is cross-linked on allocation unit ..."

"... invalid time stamp"


In addition, there were files with strange characters, which together were over 10GB while the flashdrive is only 4GB.

Having fixed the prblems with chkdsk, I again ran chkdsk and new problems were there. I can keep doing this and new problems keep popping up.

Therefore, I formatted the flashdrive and ran chkdsk. All problems were gone. I copied files from my harddrive to the flashdrive and again ran chkdsk. The problems were back.

I also ran chkdsk on the harddrive, but there were no problems with the harddrive.

I've also tried the above (formatting the flashdrive) for a second time, with the same result.

With chkdsk /r there don't seem to be any bad sectors.


Does anyone have an idea what the problem might be? (the flashsdrive is less than a year old) Thanks in advance!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.