Jump to content
CCleaner Community Forums

SpyBot S&D Not cleaning since update


Recommended Posts

I just updated to SypBot S&D 1.51 and CCleaner no longer lists SpyBot SD in the Aplicattions for cleaning. Is their a way to correct it?

 

I found that the entry in the winapp.ini for spybot 1.4 was the following:

 

[spyBot Search and Destroy]

LangSecRef=3024

Detect=HKCU\Software\PepiMK Software\SpybotSnD

Default=True

FileKey1=%allusersprofile%\Application Data\Spybot - Search & Destroy\Logs|*.*

FileKey2=%ProgramFiles%\Spybot - Search & Destroy|advdebug.txt

FileKey3=%allusersprofile%\Application Data\Spybot - Search & Destroy|Statistics.ini

FileKey4=%windir%\All Users\Application Data\Spybot - Search & Destroy\Logs|*.*

FileKey5=%windir%\All Users\Application Data\Spybot - Search & Destroy|Statistics.ini

 

 

The new verions of spybot S&D is listed in the registry as:

 

[spyBot Search and Destroy]

LangSecRef=3024

Detect=HKCU\Software\Safer Networking limited\SpybotSnD

Default=True

FileKey1=%allusersprofile%\Application Data\Spybot - Search & Destroy\Logs|*.*

FileKey2=%ProgramFiles%\Spybot - Search & Destroy|advdebug.txt

FileKey3=%allusersprofile%\Application Data\Spybot - Search & Destroy|Statistics.ini

FileKey4=%windir%\All Users\Application Data\Spybot - Search & Destroy\Logs|*.*

FileKey5=%windir%\All Users\Application Data\Spybot - Search & Destroy|Statistics.ini

 

The lines in red show the old dectect entry and the new one I entered.

 

 

I copied the entry from the winapp.ini and made winapp2.ini with the same entries and then changed the detection listed above and it show up again in CCleaner, but I am not sure of the other entries and don't want to use it until someone can confirm that I have entered it right.

 

Thanks for any help,

Normandie

Link to post
Share on other sites
Although I'm not sure why the cleaning of Statistics.ini is a necessity.

 

Andavari,

 

I don't know either, but those are the lines that were in the orignal winapp.ini shipped with CCleaner so I included them. Should that line be deleted?

 

Thanks & have a nice day,

Normandie

Link to post
Share on other sites
  • Moderators

I know it was originally included with CCleaner but it wasn't always in there I remember some time ago CC being updated to include it. Although I never knew the reason why an .ini file would be deleted from Spybot-S&D.

Link to post
Share on other sites

Generally the winapp.ini is out of date and it requires a user to audit their software and write a custom winapp2.ini. There's also differences with Vista where CCleaner doesnt delete things that are a privacy issue that cant be done due to limitations in the ini system. Vista also stores things in different areas so I think Piriform need to start seperating out the XP vs Vista requirements into seperate inis or something.

 

I think that to fix this problem Piriform should setup better tools so the community can do a better job of submitting enhancements and new detections for software. It's kinda like anti virus updates. They need to continually be done as software continually changes and new operating systems change the way applications work with the OS, as well adding new features. The current method with only having one winapp2.ini as a "sticky" isnt really meeting whats needed and the ini definitions themselves are incorrect cos they are out of date, and dont work right for Vista.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...