Jump to content

Recuva does not find erased files


Recommended Posts

I have the 095 version running on a Toshiba laptop. The scan finishes instantly without finding any files.


I have checked the disk using your suggested chkdsk options with no problems.


I then ran in debug mode with the following result:


[2007-07-26 10:43:50] [iNFO ] Recuva v1.02.095

[2007-07-26 10:43:50] [iNFO ] System Info: MS Windows XP SP2, Intel® Pentium® M processor 1400MHz, 511MB RAM, NVIDIA GeForce4 420 Go (Toshiba)

[2007-07-26 10:43:50] [ERROR] Exception: DriveNamesEnumerator.cpp(46) : The device is not ready.


[2007-07-26 10:43:50] [ERROR] Exception: DriveNamesEnumerator.cpp(46) : The device is not ready.


An older version worked fine on this computer...not sure which version.


Program runs fine on my desktop.


Thank you.

Link to comment
Share on other sites

Thanks for the error log, we'll look into this.






Hello. I tried the new file and have the same problem, no files found and the check takes less than 1 second. I then rechecked the drive with several utilities and found no problem. Let me know if you would like me to try something else.


I tried another recovery program and have the same problem. I also noted that the other program was able to check my external drive.


Recuva 095 crashes on my external drive at 81%, Recuva 097 works with my external drive.


I'm starting to think this is a registry problem or permission problem with the C:\ drive.


Recuva and FileRecovery fail to find files on the C:\ drive.



Link to comment
Share on other sites

Mr. Ron,


I am having a similar problem. If I scan my "D Drive" or any other drive other than the "C Drive", the program works fine - finds deleted files (although there appears to be an unrelated issue that the deleted files don't have the same name as the originals).


But when I scan the "C Drive" - the one with the WindowsXP operating system, it completes in less than a second and finds nothing.


I have even created a file (word.doc), saved it and then deleted it, emptied the recycle bin, and ran Recuva - nothing is found. But if I do the same test and save the file to the "D Drive", Recuva does find the file, but with a strange file name. (the original file was named "word.doc" but the one found was Di8.doc).


Any idea why the primary drive search appears to fail?

Link to comment
Share on other sites

Mr Ron,


Yes, I'm logged in as Administrator and the File System is NTFS.


Interesting, but the "D Drive" is also formatted as NTFS and Recuva finds deleted files just fine on that drive; but the "C Drive", nothing, just a very fast completion of the program scan - almost like nothing is happening.


I did just think of someting. When I look at "Start" by right-clicking, if I open "All Users" and look in Programs, Recuva is not there. Looks like it is installed under my user id only.


Is this a clue? Is there a way to make it available to "All Users?"



Anything else I can try?

Link to comment
Share on other sites

Mr. Ron,


Just noticed one more thing - when I try to scan the "C Drive", if I can read the popup screen correctly, it say "Completed Process 0%, 0 Files found" and the progress bar does not move to 100%.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.