Jump to content
CCleaner Community Forums

Systray.exe keeps Sndvol32 happy - Why?


muzak24h

Recommended Posts

Hi, I have a motherboard with integrated C-Media sound (I'm not sure how many other sound cards or chip-sets are in this same boat...) and the problem I've had seems common: "the disappearing Volume Control"

 

Before I found the fix, I had to go into Control Panel (Sounds and Audio) and uncheck "Place volume in Task bar" > apply and then re-check and apply, to make it appear again. So I Googled, and the result (and cure) was :

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

"SysTray"="\"c:\\windows\\system32\\systray.exe\""

 

Is it possible for your software to just leave this one alone? (or does that invite problems?.. :unsure: )

 

see: Google Results and Cure

 

P.S. Your software is one of most recommended and trusted vigilante's of the Internet. By stopping hidden problems before they even happen, most will never know how or when to thank you... :(

Link to post
Share on other sites
SysTray is not a required file.  It simply allows for icons such as Volume Control and a few others to be easily accessable in the taskbar by the clock.

 

 

 

Sorry, I fail to see why one would call it "not required" - I would venture a guess that most users consider a volume control important. Here's a screeny file with this add-on question:

 

If systray.exe is in fact in the system32 folder, why is CCleaner flagging this as a missing file? As can be seen in the screeny, it is there... :mellow:

 

If an executive decision was made to delete it, why? Further, if it is a constant target for malware, etc.., why not check its integrity during the install, and if it changes later, give it the :wacko: axe.

post-1309-1115411579_thumb.jpg

post-1309-1115411579_thumb.jpg

Link to post
Share on other sites
  • Moderators

CCleaner lists the file missing in "C:\WINDOWS\System32" from your CCleaner screenshot. However it looks as though it is installed in "H:\WINDOWS\System32" from your search screenshot -- that's probably the problem if you have Windows installed on the H:\ drive.

 

Edit:

I just looked through my registry on WinXP Pro and didn't even see a systray.exe listing under any of the Run areas. Perhaps it loads some other way not through the registry, it isn't in Win.ini, or System.ini either, yet all my icons load.

Link to post
Share on other sites

Hi there again,

 

In sending up that Jpeg, I had another glance at the screeny! Sometime back, I elected to install XP to a new partition and it was assigned H:

 

When the Volume problem started, I pasted the fix into Regedit just as I found it on a web forum (it assumed C: was the sysdrive) and the Volume control has not disappeared since.

 

Ok, now I know why CCleaner is flagging this... :rolleyes: Sorry everyone! But maybe someone else now has the solution to the Volume control issue...

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...