Jump to content
CCleaner Community Forums

Ian Murphy

Members
  • Content Count

    9
  • Joined

  • Last visited

Everything posted by Ian Murphy

  1. Maybe I'm missing something obvious, but if I follow the link to download recuva portable, it takes me back to the main piriform page. The only download which works is the main installer. What I'm doing is the following: Open the following web: http://www.piriform.com/recuva/builds I click on the portable download, which takes me to this page: http://www.piriform.com/recuva/download/portable and this page then reloads and displays this page: http://www.piriform.com/ Regards Ian
  2. Suggestion: An option to clear a block, or range of blocks, or compact files starting from the end of the disk. Why: With everything going virtual I often find that I have a virtual disk which has 2-3 blocks occupied at the end of a, say, 100gb disk. If you want to reduce this disk down to a more reasonable 50gb which is closer to its in-use size then you have to clear all the disk from the 50gb mark up to the end of the disk. This is often blocked by a few kb of files. To clear these blocks can take hours of defragmenting. Suggestion: Option to Distribute large files across the disk, or to leave them with xMb space after them for expansion. Why: With SQL Db or exchange files the files are constantly growing. Given that you have chosen the option to move large files to the end of the disk. A 50gb, when it expands by 1Mb, that 1Mb will not be at the end of the file, so on the next run of defraggler it will have to move the whole 50Gb to fit 1Mb in at the end of the disk... not good. It would be better to be able to distribute big files across the disk, or to move them to a space with xMb free after the file. I've suggested this before but never seen any reaction - positive or negative.
  3. Suggestion: Create a new 'Defraggler suggestions' thread. The current one is a monster. How about 'Defraggler suggestions 2011' so you can start a new one each year.
  4. On big disks the dots representing the blocks end up representing a huge number of blocks. It is possible to make the dots smaller or have an option to, say, reduce them down to a single dot with no border? This is only cosmetic but when you're sitting there watching a defrag the movement onscreen is very little while there are a lot of blocks getting moved about. Hey, what can I say, I'm a fan of flashing lights! Ian
  5. The suggestion makes sense but unfortunately is not possible. Defraggler doesn't actually do the disk IO. Windows NTFS has a special call to move a block from one place to another which was created especially for defragmenting. All you can do is move a block from one place to another. The API is safe, so the author of a defragmenter doesn't have to worry about disk corruption, NTFS takes care of that. The problem is that you are limited to what the API provides and that is move-block. If you use the contig.exe utility from sysinternals in verbose mode it tells you which block it is moving - essentially it displays a line of log for each call to the API. Ian
  6. I've been trying to get a big disk defragmented and have been having a bit of a nightmare. The disk contains virtual machines with dynamic disks and a backup directory for an SQL server - which changes every day. Now, the problem is that the virtual machine disks are huge. I have configured it to move the big (>10gb) files to the end of the disk, however if you stop defraggler and restart it, it finds that the last file on the disk has extended by a few Mb and it starts moving the 200Gb of virtual disk files in front of it to make a space - it never finishes and ends up moving the last file on the disk constantly rather than defragmenting the remaining virtual disks. Would it be possible to add a way to leave a gap for expansion? Now I realise that this generates another problem. On the next defrag the gap will have reduced due to expansion and so the logic would say to move it again to increase the gap size, which would defeat the purpose. Maybe a facility which allowed the sysadmin to specify position on the disk for a file. I'm thinking specifically of defragmenting servers where you always have big files. Maybe a 'don't touch the first fragment of this file' marker. At least this would allow us to defragment these files down to a couple of fragments. Anyone got any good ideas? What other tecniques exist out there? Everyone has got to be hitting the same problem. Ian
  7. This was fixed in a subsequent release - one of my systems suddenly started going slow every day because there had been scheduled jobs executing and failing every day until after one of the upgrades it suddenly popped into life. Ian
  8. Just noticed that there is a debug mode. This is the log showing what fails when I try to schedule a defrag. [2008-10-20] [12:44:08.813] 00b48 1 CVolumeManagerBase::GetBasicVolumeInfo#217 Unsupported drive type 5 for volume Z: [2008-10-20] [12:44:08.813] 00b48 1 CVolumeManagerBase::UpdateVolume#298 Finish update for bvi Z:. [2008-10-20] [12:44:21.891] 01188 1 CVolumeNavigator::SelectVolume#271 New volume selected: A:. [2008-10-20] [12:44:21.891] 01188 1 CFilesListViewImpl::DoSort#263 Sorting 0 elements took 0.0000 seconds [2008-10-20] [12:44:21.891] 01188 1 FindResourceNameFromOrdinal::FindResourceIdFromOrdinal::BeginSearching#73 EnumResourceNames failed (hr=0x00000000) [2008-10-20] [12:44:24.015] 01188 1 CFilesListViewImpl::DoSort#263 Sorting 0 elements took 0.0000 seconds [2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#150 VolumesMap size = 5 [2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task [2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task [2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task [2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task [2008-10-20] [12:44:24.922] 01188 1 CTaskSchedule::RefreshVolumesData#172 Adding empty task [2008-10-20] [12:44:25.219] 01188 1 CTaskSchedule::LoadTasks#281 Error occured while getting task data from Task Scheduler. HRESULT: -2147216631 [2008-10-20] [12:44:35.484] 01188 1 CTaskSchedule::SaveTasks#239 AddTask Error. HRESULT: -2147024809 [2008-10-20] [12:44:38.562] 01188 1 CMainFrame::OnDestroy#439 Entering CMainFrame::OnDestroy [2008-10-20] [12:44:38.562] 01188 1 CVolumeNavigator::Shutdown#74 Entering CVolumeNavigator::Shutdown [2008-10-20] [12:44:38.562] 01188 1 CVolumeNavigator::Shutdown#74 Leaving CVolumeNavigator::Shutdown [2008-10-20] [12:44:38.562] 01188 1 CVolumeManager::Shutdown#35 Entering CVolumeManager::Shutdown [2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x00000574 [2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x00000470 [2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x0000048c [2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::ChangeNotificationOwner::~ChangeNotificationOwner#57 Unregistered notification for handle: 0x000006a4 [2008-10-20] [12:44:38.671] 01188 1 CVolumeManager::Shutdown#35 Leaving CVolumeManager::Shutdown [2008-10-20] [12:44:38.671] 01188 1 CMainFrame::OnDestroy#439 Leaving CMainFrame::OnDestroy [2008-10-20] [12:44:38.671] 01188 1 CMainFrame::~CMainFrame#131 Entering CMainFrame::~CMainFrame [2008-10-20] [12:44:38.671] 01188 1 CMainFrame::~CMainFrame#131 Leaving CMainFrame::~CMainFrame The pertinient line seems to be CTaskSchedule::LoadTasks#281 Error occured while getting task data from Task Scheduler. HRESULT: -2147216631 I googled this but didn't find anything of use. However in task scheduler I found a task half programed. In the Task properties the Execute or Run field (not sure - my pc is in spanish), contains c:\df.exe c: and the schedule is blank. Defraggler is installed into C:\Archivos de Programa\Defraggler - the equiv of program files under spanish XP. Hope this is of some use in debugging the problem. Ian
  9. I've just tried out the latest version - 1.3.094 - and can confirm that this problem is still occuring. I am running XP pro Spanish, fully patched. I have tried this using a domain admin account - i.e full privs and still no go. I've tried the select different drive solution mentioned above but it does nothing on my machine. A better help message you be a good idea here - what is it that its trying to do? It should say what it failed to do and what error was returned and by what. Excellent tool btw Ian
×
×
  • Create New...